aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>2015-11-07 17:12:11 +0100
committerJonathan McCrohan <jmccrohan@gmail.com>2015-11-11 23:38:00 +0000
commit4100e103fc4f1d7e3da860c1b0c34cb73356c4b7 (patch)
tree262b341cea3746780e26186012f1958547c9ea04 /admin
parente3b0a20c445ec4a3c4868ceee4f273eef887e01e (diff)
muninlite: Enable the df plugin again and fix parsing disk usage
Closes: #1926 Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/muninlite/Makefile2
-rw-r--r--admin/muninlite/patches/001-fix_disks.patch10
-rw-r--r--admin/muninlite/patches/001-no_disks.patch12
3 files changed, 11 insertions, 13 deletions
diff --git a/admin/muninlite/Makefile b/admin/muninlite/Makefile
index 46fc8c4f8..4cf700ba9 100644
--- a/admin/muninlite/Makefile
+++ b/admin/muninlite/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=muninlite
PKG_VERSION:=1.0.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/admin/muninlite/patches/001-fix_disks.patch b/admin/muninlite/patches/001-fix_disks.patch
new file mode 100644
index 000000000..8c3027289
--- /dev/null
+++ b/admin/muninlite/patches/001-fix_disks.patch
@@ -0,0 +1,10 @@
+--- a/plugins/df 2015-11-07 17:05:46.000000000 +0100
++++ b/plugins/df 2015-11-07 17:05:49.183925905 +0100
+@@ -19,6 +19,6 @@
+ do
+ PINFO=$(df -P $PART | tail -1);
+ PNAME=$(echo $PINFO | cut -d\ -f1 | sed 's/[\/.-]/_/g')
+- echo "$PNAME.value" $(echo $PINFO | cut -f5 -d\ | sed -e 's/\%//g')
++ echo "$PNAME.value" $(echo $PINFO | sed -e 's/\%//g' -e 's/ */ /g' | cut -f5 -d' ')
+ done
+ }
diff --git a/admin/muninlite/patches/001-no_disks.patch b/admin/muninlite/patches/001-no_disks.patch
deleted file mode 100644
index bf9b2b1c5..000000000
--- a/admin/muninlite/patches/001-no_disks.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,7 @@
-
-
--PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate plugindir_
--#PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
-+#PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate plugindir_
-+PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
-
- munin-node: plugins/* munin-node.conf
- @VERSION=$$(cat VERSION); \