aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-10-29 15:45:45 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-29 15:45:45 +0100
commit3dfb00c6c6758524282c6fa4a1995280ea613e9c (patch)
treea03a42db13e3afb40e2e33fea4cb3e8ae8e558ef /admin
parente8914a2a5762392f444afb9bbe86b429cda4ca29 (diff)
zabbix: move to PCRE2 library
Move to PCRE2 library as PCRE is not EOL and won't receive any security updates anymore. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/zabbix/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index 721cdb1b4..e91cf986f 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=6.2.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/$(basename $(PKG_VERSION))/ \
@@ -57,7 +57,7 @@ define Package/zabbix/Default
TITLE:=Zabbix
URL:=https://www.zabbix.com/
USERID:=zabbix=53:zabbix=53
- DEPENDS+=$(ICONV_DEPENDS) +libpcre +zlib
+ DEPENDS+=$(ICONV_DEPENDS) +libpcre2 +zlib
endef
define Package/zabbix-agentd
@@ -263,7 +263,7 @@ CONFIGURE_ARGS+= \
$(if $(CONFIG_ZABBIX_POSTGRESQL),--with-postgresql) \
$(if $(CONFIG_ZABBIX_SQLITE),--with-sqlite3=$(STAGING_DIR)/usr) \
--with-libevent=$(STAGING_DIR)/usr/include/libevent \
- --with-libpcre=$(STAGING_DIR)/usr/include \
+ --with-libpcre2=$(STAGING_DIR)/usr/include \
--with-zlib=$(STAGING_DIR)/usr/include
ifeq ($(BUILD_VARIANT),openssl)