aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2024-03-05 20:44:47 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-03-19 13:25:40 +0100
commit1e14d95d78d03ab163653166652972ca3e8c366e (patch)
tree5392b0743fa567a4f2f1c622db1df57a319f6abc /admin
parentbd591fb7b00db5887a412d5f281c00a558f57dc8 (diff)
syslog-ng: enable http module based on zlib support in curl
Since version 4.4.0, syslog-ng added compression to http() destination using zlib from curl. [1] However, zlib is currently disabled in curl [2] and it prevented syslog-ng to start. This commit changes the configuration opinion to enable http module only if zlib support is enabled for curl and as well it adds dependency for zlib (in that case). If the zlib is disabled, then it disables http module, so syslog-ng can start and thus zlib dependency is not required. [1] https://gitlab.nic.cz/turris/os/packages/-/issues/932 [2] https://github.com/openwrt/packages/blob/93cbaacbfb13048ad378520a7afea7c9027dd1d6/net/curl/Config.in#L134 Fixes: 4dd49d7c3cd571107958154f1ed1ec8d8dba7464 ("syslog-ng: update to version 4.4.0") Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/syslog-ng/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/admin/syslog-ng/Makefile b/admin/syslog-ng/Makefile
index 842d447d2..13b7fa017 100644
--- a/admin/syslog-ng/Makefile
+++ b/admin/syslog-ng/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=syslog-ng
PKG_VERSION:=4.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later GPL-2.0-or-later
@@ -21,6 +21,7 @@ PKG_BUILD_DEPENDS:= \
PKG_CONFIG_DEPENDS:= \
CONFIG_IPV6 \
+ CONFIG_LIBCURL_ZLIB
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -33,7 +34,7 @@ define Package/syslog-ng
CATEGORY:=Administration
TITLE:=A powerful syslog daemon
URL:=https://www.syslog-ng.com/products/open-source-log-management/
- DEPENDS:=+libpcre2 +glib2 +libopenssl +libpthread +librt +zlib +libdbi +libjson-c +libcurl +libuuid +SYSLOGNG_LOGROTATE:logrotate
+ DEPENDS:=+libpcre2 +glib2 +libopenssl +libpthread +librt +libdbi +libjson-c +libcurl +libuuid +SYSLOGNG_LOGROTATE:logrotate +LIBCURL_ZLIB:zlib
endef
define Package/syslog-ng/description
@@ -91,7 +92,7 @@ CONFIGURE_ARGS += \
--with-jsonc=system \
--enable-cpp=no \
--enable-json=yes \
- --enable-http=yes \
+ $(if $(CONFIG_LIBCURL_ZLIB),--enable-http=yes,--enable-http=no) \
--disable-smtp \
--disable-mqtt \
--disable-redis \