aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2024-02-20 15:48:04 +0800
committerTianling Shen <cnsztl@immortalwrt.org>2024-02-20 15:49:07 +0800
commit187b52c95afc826213ba3e204e43ed009d8e8908 (patch)
tree0b5d7084285bfcdb1192eb35d68d444eecb7e24d /admin
parent870d09c5dd577a05cd850228b4a2e4aaa3f4362c (diff)
btop: Update to 1.3.2
Synced LDFLAGS from upstream Makefile. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'admin')
-rw-r--r--admin/btop/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/admin/btop/Makefile b/admin/btop/Makefile
index f5efc5ee2..46e86ad49 100644
--- a/admin/btop/Makefile
+++ b/admin/btop/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=btop
-PKG_VERSION:=1.3.0
+PKG_VERSION:=1.3.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://codeload.github.com/aristocratos/btop/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=375e078ce2091969f0cd14030620bd1a94987451cf7a73859127a786006a32cf
+PKG_HASH:=331d18488b1dc7f06cfa12cff909230816a24c57790ba3e8224b117e3f0ae03e
PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
PKG_LICENSE:=Apache-2.0
@@ -33,14 +33,11 @@ define Package/btop/description
C++ version and continuation of bashtop and bpytop.
endef
+BTOP_LDFLAGS:=-pthread -DFMT_HEADER_ONLY -D_FILE_OFFSET_BITS=64
MAKE_FLAGS+= \
PLATFORM=Linux \
OPTFLAGS="$(TARGET_CXXFLAGS)" \
- LDCXXFLAGS="$(TARGET_LDFLAGS) -pthread"
-
-ifneq ($(CONFIG_USE_MUSL),)
- TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
-endif
+ LDCXXFLAGS="$(TARGET_LDFLAGS) $(BTOP_LDFLAGS)"
define Package/btop/install
$(INSTALL_DIR) $(1)/usr/bin