aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-23 20:24:37 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:24 +0800
commit0dfc1b508d5e5b361978ef9783cb63775176c305 (patch)
tree87d123b9d63916b84de9d88e81502e38a6bf4a0b /admin
parent9db7284d589dc8490f8c7dbe56af731fce953eda (diff)
rust: Use make's jobserver when building packages
This allows cargo to use make's jobserver when building packages, by marking the cargo command as recursive (with the + prefix[1]) and setting MAKEFLAGS. This also: * Give cargo/x.py the build directory instead of having to change the current directory (and opening subshells) * Set PKG_BUILD_PARALLEL/HOST_BUILD_PARALLEL for Rust packages to enable the use of make's jobserver [1]: https://www.gnu.org/software/make/manual/html_node/POSIX-Jobserver.html Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'admin')
1 files changed, 1 insertions, 0 deletions
diff --git a/admin/bottom/Makefile b/admin/bottom/Makefile
index bdd049a29..556b11b23 100644
--- a/admin/bottom/Makefile
+++ b/admin/bottom/Makefile
@@ -17,6 +17,7 @@ PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_DEPENDS:=rust/host
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include ../../lang/rust/rust-package.mk