aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2023-04-21 16:32:27 +0000
committerPaul Spooren <mail@aparcar.org>2023-04-21 22:46:58 +0200
commit0c10c224be81f9221dabfab449855ab6718d2a0c (patch)
treec7e9f983c60cbf9ae17bce5f64dc72963c67a6d3 /admin
parent018fcf3ccd3c65c92f7c9467ab35f345fbd2c1ae (diff)
treewide: remove AUTORELEASE
Automatically compute and substitute current values for all $(AUTORELEASE) instances as this feature is deprecated and shouldn't be used. The following temporary change was made to the core: diff --git a/rules.mk b/rules.mk index 57d7995d4fa8..f16367de87a8 100644 --- a/rules.mk +++ b/rules.mk @@ -429,7 +429,7 @@ endef abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1)))) COMMITCOUNT = $(if $(DUMP),0,$(call commitcount)) -AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1)) +AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) all: FORCE: ; And this command used to fix affected packages: for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \ sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/download done Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/btop/Makefile2
-rw-r--r--admin/debian-archive-keyring/Makefile2
-rw-r--r--admin/netdata/Makefile2
-rw-r--r--admin/nload/Makefile2
-rw-r--r--admin/syslog-ng/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/admin/btop/Makefile b/admin/btop/Makefile
index 281249570..8b8888b50 100644
--- a/admin/btop/Makefile
+++ b/admin/btop/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=btop
PKG_VERSION:=1.2.13
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://codeload.github.com/aristocratos/btop/tar.gz/v$(PKG_VERSION)?
diff --git a/admin/debian-archive-keyring/Makefile b/admin/debian-archive-keyring/Makefile
index 21c906afe..cf2d179be 100644
--- a/admin/debian-archive-keyring/Makefile
+++ b/admin/debian-archive-keyring/Makefile
@@ -3,7 +3,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=debian-archive-keyring
PKG_VERSION:=2021.1.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=debian-archive-keyring_2021.1.1_all.deb
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debian-archive-keyring/
diff --git a/admin/netdata/Makefile b/admin/netdata/Makefile
index f4d00786d..3552536e6 100644
--- a/admin/netdata/Makefile
+++ b/admin/netdata/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=netdata
PKG_VERSION:=1.33.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=4
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>, Daniel Engberg <daniel.engberg.lists@pyret.net>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/admin/nload/Makefile b/admin/nload/Makefile
index b987507c2..77abc29cb 100644
--- a/admin/nload/Makefile
+++ b/admin/nload/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nload
PKG_VERSION:=0.7.4
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/rolandriegel/nload/tar.gz/v$(PKG_VERSION)?
diff --git a/admin/syslog-ng/Makefile b/admin/syslog-ng/Makefile
index a225b6afa..7a214f152 100644
--- a/admin/syslog-ng/Makefile
+++ b/admin/syslog-ng/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=syslog-ng
PKG_VERSION:=4.1.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
PKG_LICENSE:=LGPL-2.1-or-later GPL-2.0-or-later