aboutsummaryrefslogtreecommitdiff
path: root/admin/nyx/Makefile
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-02-17 16:52:24 +0100
committerJavier Marcet <javier@marcet.info>2020-02-17 20:50:32 +0100
commit8ab8e10e1ac58fac896442ad4580b65deeff2e6e (patch)
treee08208db1387ee4a3bf75dd86ee319d490f8b4ae /admin/nyx/Makefile
parent4f114a5ed470a0bd7ec4e762af3ea6a3a3768455 (diff)
nyx: Terminal status monitor for Tor
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'admin/nyx/Makefile')
-rw-r--r--admin/nyx/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/admin/nyx/Makefile b/admin/nyx/Makefile
new file mode 100644
index 000000000..a572fb893
--- /dev/null
+++ b/admin/nyx/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nyx
+PKG_VERSION:=2.1.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=nyx
+PKG_HASH:=88521488d1c9052e457b9e66498a4acfaaa3adf3adc5a199892632f129a5390b
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=GPL-3.0-only
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/python/python3-package.mk
+
+define Package/nyx
+ SECTION:=admin
+ CATEGORY:=Administration
+ URL:=https://nyx.torproject.org/
+ TITLE:=Terminal status monitor for Tor
+ DEPENDS:=+python3 +python3-stem
+ VARIANT:=python3
+endef
+
+define Package/nyx/description
+ Nyx is a command-line monitor for Tor. With this you can get detailed real-time
+ information about your relay such as bandwidth usage, connections, logs, and
+ much more.
+endef
+
+$(eval $(call Py3Package,nyx))
+$(eval $(call BuildPackage,nyx))
+$(eval $(call BuildPackage,nyx-src))