aboutsummaryrefslogtreecommitdiff
path: root/admin/netdata/patches
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-12-26 01:51:58 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-12-26 01:53:11 +0100
commit6c5e3e5cca86d983008daddf22b639dbc5da8398 (patch)
tree096f3a458e19aba98c25f60e5c4a6ae2cf49481a /admin/netdata/patches
parent079ffbd44e91f44081cfc78521ef62b8e1411fce (diff)
netdata: update to version 1.28.0
Refreshed patches and removed one backported patch Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'admin/netdata/patches')
-rw-r--r--admin/netdata/patches/003-extra-patch-web_gui_main.js.patch2
-rw-r--r--admin/netdata/patches/004-patch-collectors_python.d.plugin_Makefile.am.patch4
-rw-r--r--admin/netdata/patches/007-dont-check-for-ebpf-dependencies-when-it-is-disabled.patch79
3 files changed, 3 insertions, 82 deletions
diff --git a/admin/netdata/patches/003-extra-patch-web_gui_main.js.patch b/admin/netdata/patches/003-extra-patch-web_gui_main.js.patch
index 0d3862f0b..f2b86b4ca 100644
--- a/admin/netdata/patches/003-extra-patch-web_gui_main.js.patch
+++ b/admin/netdata/patches/003-extra-patch-web_gui_main.js.patch
@@ -1,6 +1,6 @@
--- a/web/gui/main.js
+++ b/web/gui/main.js
-@@ -745,11 +745,7 @@ function renderMyNetdataMenu(machinesArr
+@@ -759,11 +759,7 @@ function renderMyNetdataMenu(machinesArr
if (!isSignedIn()) {
if (!NETDATA.registry.isRegistryEnabled()) {
html += (
diff --git a/admin/netdata/patches/004-patch-collectors_python.d.plugin_Makefile.am.patch b/admin/netdata/patches/004-patch-collectors_python.d.plugin_Makefile.am.patch
index eaf300b37..e4816009e 100644
--- a/admin/netdata/patches/004-patch-collectors_python.d.plugin_Makefile.am.patch
+++ b/admin/netdata/patches/004-patch-collectors_python.d.plugin_Makefile.am.patch
@@ -1,8 +1,8 @@
--- a/collectors/python.d.plugin/Makefile.am
+++ b/collectors/python.d.plugin/Makefile.am
-@@ -142,109 +142,3 @@ dist_third_party_DATA = \
- python_modules/third_party/boinc_client.py \
+@@ -145,109 +145,3 @@ dist_third_party_DATA = \
python_modules/third_party/monotonic.py \
+ python_modules/third_party/filelock.py \
$(NULL)
-
-pythonyaml2dir=$(pythonmodulesdir)/pyyaml2
diff --git a/admin/netdata/patches/007-dont-check-for-ebpf-dependencies-when-it-is-disabled.patch b/admin/netdata/patches/007-dont-check-for-ebpf-dependencies-when-it-is-disabled.patch
deleted file mode 100644
index c2246779e..000000000
--- a/admin/netdata/patches/007-dont-check-for-ebpf-dependencies-when-it-is-disabled.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From bb405e3c274ca8860c974a720071d346b16c8462 Mon Sep 17 00:00:00 2001
-From: Tomas Kopal <Tomas.Kopal@eccam.com>
-Date: Tue, 6 Oct 2020 13:38:08 +0200
-Subject: [PATCH] Don't check for ebpf dependencies if ebpf is disabled.
-
----
- configure.ac | 56 +++++++++++++++++++++++++++-------------------------
- 1 file changed, 29 insertions(+), 27 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 57f6c0b1cb3a..5f13b4feb0d1 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -989,36 +989,38 @@ AM_CONDITIONAL([ENABLE_PLUGIN_PERF], [test "${enable_plugin_perf}" = "yes"])
- # -----------------------------------------------------------------------------
- # ebpf.plugin
-
--PKG_CHECK_MODULES(
-- [LIBELF],
-- [libelf],
-- [have_libelf=yes],
-- [have_libelf=no]
--)
-+if test "${build_target}" = "linux" -a "${enable_ebpf}" != "no"; then
-+ PKG_CHECK_MODULES(
-+ [LIBELF],
-+ [libelf],
-+ [have_libelf=yes],
-+ [have_libelf=no]
-+ )
-
--AC_CHECK_TYPE(
-- [struct bpf_prog_info],
-- [have_bpf=yes],
-- [have_bpf=no],
-- [#include <linux/bpf.h>]
--)
-+ AC_CHECK_TYPE(
-+ [struct bpf_prog_info],
-+ [have_bpf=yes],
-+ [have_bpf=no],
-+ [#include <linux/bpf.h>]
-+ )
-
--AC_CHECK_FILE(
-- externaldeps/libbpf/libbpf.a,
-- [have_libbpf=yes],
-- [have_libbpf=no]
--)
-+ AC_CHECK_FILE(
-+ externaldeps/libbpf/libbpf.a,
-+ [have_libbpf=yes],
-+ [have_libbpf=no]
-+ )
-
--AC_MSG_CHECKING([if ebpf.plugin should be enabled])
--if test "${build_target}" = "linux" -a \
-- "${enable_ebpf}" != "no" -a \
-- "${have_libelf}" = "yes" -a \
-- "${have_bpf}" = "yes" -a \
-- "${have_libbpf}" = "yes"; then
-- OPTIONAL_BPF_CFLAGS="${LIBELF_CFLAGS} -I externaldeps/libbpf/include"
-- OPTIONAL_BPF_LIBS="externaldeps/libbpf/libbpf.a ${LIBELF_LIBS}"
-- AC_DEFINE([HAVE_LIBBPF], [1], [libbpf usability])
-- enable_ebpf="yes"
-+ AC_MSG_CHECKING([if ebpf.plugin should be enabled])
-+ if test "${have_libelf}" = "yes" -a \
-+ "${have_bpf}" = "yes" -a \
-+ "${have_libbpf}" = "yes"; then
-+ OPTIONAL_BPF_CFLAGS="${LIBELF_CFLAGS} -I externaldeps/libbpf/include"
-+ OPTIONAL_BPF_LIBS="externaldeps/libbpf/libbpf.a ${LIBELF_LIBS}"
-+ AC_DEFINE([HAVE_LIBBPF], [1], [libbpf usability])
-+ enable_ebpf="yes"
-+ else
-+ enable_ebpf="no"
-+ fi
- else
- enable_ebpf="no"
- fi