aboutsummaryrefslogtreecommitdiff
path: root/admin/htop
diff options
context:
space:
mode:
authorEtienne Champetier <champetier.etienne@gmail.com>2021-10-03 22:11:08 -0400
committerEtienne Champetier <champetier.etienne@gmail.com>2021-10-03 22:46:07 -0400
commit253e3f558c9d5d6ee43a7e870ef60f8a1c0c80c7 (patch)
tree057d03025ae8bbb4d559dfe4faed9955a77ab50a /admin/htop
parentbaf556f0de2355bf9ef82b5cbcae3477d4d4ca8d (diff)
htop: explicitly disable some build options
Since 3.1.0 delayacct option is enabled if the needed dependencies are detected, it was previously disabled. Sensors also check for dependency so we need to explicitly disable it when not enabled. Fixes 5f916720551ad5ea5ac86cf5e122fc2c0c34cc15 Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
Diffstat (limited to 'admin/htop')
-rw-r--r--admin/htop/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/admin/htop/Makefile b/admin/htop/Makefile
index e2db3847e..179863ad5 100644
--- a/admin/htop/Makefile
+++ b/admin/htop/Makefile
@@ -56,9 +56,10 @@ define Package/htop/config
endef
CONFIGURE_ARGS += \
- $(if $(CONFIG_HTOP_LMSENSORS),--enable-sensors,) \
+ --$(if $(CONFIG_HTOP_LMSENSORS),en,dis)able-sensors \
--enable-affinity \
- --enable-capabilities=no \
+ --disable-capabilities \
+ --disable-delayacct \
--disable-unicode \
--disable-hwloc