aboutsummaryrefslogtreecommitdiff
path: root/admin/debian-archive-keyring
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-11-20 04:40:17 +0000
committerDaniel Golle <daniel@makrotopia.org>2020-11-20 04:46:30 +0000
commit832292b6390039acb35976d0fde8611bf386fec3 (patch)
treed6dfec0c868272cf3b69a2402e7419a1a5ca7c3d /admin/debian-archive-keyring
parentbb704ffd4cd65fac3db2b323454b9a7e7c9e0302 (diff)
debian-archive-keyring: add new package
Grab debian-archive-keyring from debian.org to easy use of debootstrap. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'admin/debian-archive-keyring')
-rw-r--r--admin/debian-archive-keyring/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/admin/debian-archive-keyring/Makefile b/admin/debian-archive-keyring/Makefile
new file mode 100644
index 000000000..dc71b87d2
--- /dev/null
+++ b/admin/debian-archive-keyring/Makefile
@@ -0,0 +1,42 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=debian-archive-keyring
+PKG_VERSION:=2019.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=debian-archive-keyring_2019.1_all.deb
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debian-archive-keyring/
+PKG_HASH:=9cefd8917f3d97a999c136aa87f04a3024408b5bc1de470de7d6dfa5e4bd4361
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+PKG_LICENSE:=Unique
+PKG_LICENSE_FILES:=usr/share/doc/debian-archive-keyring/copyright
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/debian-archive-keyring
+ SECTION:=admin
+ CATEGORY:=Administration
+ TITLE:=Debian Archive keyring
+ URL:=https://salsa.debian.org/release-team/debian-archive-keyring
+ PKGARCH:=all
+endef
+
+define Build/Prepare
+ $(AR) p $(DL_DIR)/$(PKG_SOURCE) data.tar.xz | $(TAR) -xJC $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/debian-archive-keyring/install
+ $(INSTALL_DIR) $(1)/usr/share/keyring
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/keyrings/*.gpg $(1)/usr/share/keyring
+endef
+
+$(eval $(call BuildPackage,debian-archive-keyring))