aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Ryzhov <github@ryzhov-al.ru>2019-09-26 15:51:13 +0300
committerRosen Penev <rosenp@gmail.com>2020-02-08 23:08:58 -0800
commitfed1b3b11bf9361dbbd158a1018c701d8180e49b (patch)
treef05aa30cc252dc236cbd21393df40fc636e3cfcf
parent616b86569705f8a020b30d76796f238eb49287fe (diff)
perl: define $sysroot for extensions
Signed-off-by: Alexander Ryzhov <github@ryzhov-al.ru> Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--lang/perl/Makefile3
-rw-r--r--lang/perl/files/base.config1
-rw-r--r--lang/perl/patches/998-Errno_errno.h_path.patch11
3 files changed, 13 insertions, 2 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index d0606a962..84d256d2d 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -11,7 +11,7 @@ include perlver.mk
PKG_NAME:=perl
PKG_VERSION:=$(PERL_VERSION)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=\
https://cpan.metacpan.org/src/5.0 \
@@ -105,6 +105,7 @@ define Build/Configure
-Dowrt:threads=$(if $(CONFIG_PERL_THREADS),yes,no) \
-Dowrt:staging_dir='$(STAGING_DIR)' \
-Dowrt:host_perl_prefix='$(HOST_PERL_PREFIX)' \
+ -Dsysroot='$(TOOLCHAIN_DIR)' \
files/version.config \
files/base.config \
files/$(patsubst i386,i486,$(ARCH)).config \
diff --git a/lang/perl/files/base.config b/lang/perl/files/base.config
index 90a2cfbf6..f2d18f547 100644
--- a/lang/perl/files/base.config
+++ b/lang/perl/files/base.config
@@ -938,7 +938,6 @@ stdio_ptr='((fp)->_ptr)'
stdio_stream_array=''
submit=''
sysman='/usr/share/man/man1'
-sysroot=''
tail=''
tar=''
targetdir=''
diff --git a/lang/perl/patches/998-Errno_errno.h_path.patch b/lang/perl/patches/998-Errno_errno.h_path.patch
new file mode 100644
index 000000000..f221dd938
--- /dev/null
+++ b/lang/perl/patches/998-Errno_errno.h_path.patch
@@ -0,0 +1,11 @@
+--- a/ext/Errno/Errno_pm.PL
++++ b/ext/Errno/Errno_pm.PL
+@@ -133,7 +133,7 @@
+ # Some Linuxes have weird errno.hs which generate
+ # no #file or #line directives
+ my ($linux_errno_h) = grep { -e $_ } map { "$_/errno.h" }
+- "$sysroot/usr/include", "$sysroot/usr/local/include",
++ "$sysroot/usr/include", "$sysroot/usr/local/include", "$sysroot/include",
+ split / / => $Config{locincpth} or
+ die "Cannot find errno.h";
+ $file{$linux_errno_h} = 1;