aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-17 14:00:41 -0800
committerRosen Penev <rosenp@gmail.com>2019-11-18 15:21:13 -0800
commitfea1468506c00f231d32fc14d93c9103005d8a24 (patch)
tree662300ad1674a8043383ea965a2cefa768444f98
parent0150459a78519c8a421a1ad8a164f0b22d74d0e6 (diff)
cifs-utils: Add smbinfo utility
Switched to PKG_INSTALL for simplicity. Added PKG_BUILD_PARALLEL for faster compilation. Added InstallDev section. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/cifs-utils/Makefile32
1 files changed, 27 insertions, 5 deletions
diff --git a/net/cifs-utils/Makefile b/net/cifs-utils/Makefile
index b76b27f83..bb9b42cfa 100644
--- a/net/cifs-utils/Makefile
+++ b/net/cifs-utils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cifs-utils
PKG_VERSION:=6.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.samba.org/pub/linux-cifs/cifs-utils/
@@ -20,18 +20,26 @@ PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:debian:cifs-utils
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/cifsmount
SECTION:=net
CATEGORY:=Network
DEPENDS:=+kmod-fs-cifs
- TITLE:=CIFS mount utilities
+ TITLE:=CIFS mount
URL:=https://wiki.samba.org/index.php/LinuxCIFS_utils
endef
-TARGET_CFLAGS += $(FPIC) -ffunction-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+define Package/smbinfo
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+kmod-fs-cifs
+ TITLE:=SMB info
+ URL:=https://wiki.samba.org/index.php/LinuxCIFS_utils
+endef
CONFIGURE_ARGS += \
--disable-cifsupcall \
@@ -45,9 +53,23 @@ CONFIGURE_ARGS += \
--disable-man \
--without-libcap
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/cifsidmap.h $(1)/usr/include/
+endef
+
define Package/cifsmount/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount.cifs $(1)/usr/sbin/
+endef
+
+define Package/smbinfo/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/smbinfo $(1)/usr/bin/
endef
$(eval $(call BuildPackage,cifsmount))
+$(eval $(call BuildPackage,smbinfo))