aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2024-02-19 14:54:08 +0100
committerFlorian Eckert <fe@dev.tdt.de>2024-02-20 21:35:16 +0100
commitfe736b2f8c415e6d590931f1f1f504e1d18c579b (patch)
tree958bd40c4446269f6ce812add75bfdcc1493d3be
parentc0da9fcbcb872e59b733d58d644843dd1fec755c (diff)
openvpn: fix start_path_instance function
Check the conffile existance (with .conf extension), before calling the function 'start_path_instance'. This fixes errors with non-existing and wrong spelling instances. Signed-off-by: Dirk Brenken <dev@brenken.org> - Update commit description Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--net/openvpn/Makefile2
-rw-r--r--net/openvpn/files/openvpn.init3
2 files changed, 2 insertions, 3 deletions
diff --git a/net/openvpn/Makefile b/net/openvpn/Makefile
index 365fed6c7..8d35c7477 100644
--- a/net/openvpn/Makefile
+++ b/net/openvpn/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
PKG_VERSION:=2.6.8
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE_URL:=\
https://build.openvpn.net/downloads/releases/ \
diff --git a/net/openvpn/files/openvpn.init b/net/openvpn/files/openvpn.init
index 89d25b59c..5c1beb0e3 100644
--- a/net/openvpn/files/openvpn.init
+++ b/net/openvpn/files/openvpn.init
@@ -281,7 +281,7 @@ start_service() {
if [ -n "$instance" ]; then
if [ "$instance_found" -gt 0 ]; then
start_uci_instance "$instance"
- else
+ elif [ -f "${PATH_INSTANCE_DIR}/${instance}.conf" ]; then
start_path_instance "$instance"
fi
else
@@ -299,4 +299,3 @@ start_service() {
service_triggers() {
procd_add_reload_trigger openvpn
}
-