aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2015-12-15 12:18:41 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2015-12-15 12:18:41 +0200
commitfdebb21d76a9ceb61b41cc5d47a5d9ae32a358d7 (patch)
treef7f8f4f9352f69e73bccad7293994305c2649c67
parent5b64b487157f6d4fe8bb253d6090a14c75d81c13 (diff)
parent1c74804bc59cfd9b607c4d3faac5197e6006c449 (diff)
Merge pull request #2127 from commodo/ola-fix-build
ola: fix build (linking issue TCPSocket::ReadDescriptor() const)
-rw-r--r--net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch b/net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch
new file mode 100644
index 000000000..fe1acdfc5
--- /dev/null
+++ b/net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+index 22647be..7dcf0de 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -32,7 +32,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = --enable-python-libs
+ COMMON_CXXFLAGS_ONLY_WARNINGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+- -Wall -Wformat -W -fvisibility-inlines-hidden \
++ -Wall -Wformat -W \
+ $(libprotobuf_CFLAGS)
+
+ COMMON_CXXFLAGS = $(COMMON_CXXFLAGS_ONLY_WARNINGS)