aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Ryzhov <github@ryzhov-al.ru>2015-12-08 02:06:51 -0500
committerÁlvaro Fernández Rojas <noltari@gmail.com>2015-12-16 23:01:51 +0100
commitfc2a2dadb1860e6d15a7e50425e6cab55670f3d0 (patch)
treeccb389f59bf366bd945db1e22e8fbd224e30254d
parent70c2c21ad4cf27f449da552d317f950ab5d64463 (diff)
unzip: enable unicode support and avoid packing the same binary twice
Closes https://github.com/openwrt/packages/pull/2081. Signed-off-by: Alexander Ryzhov <openwrt@ryzhov-al.ru> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
-rw-r--r--utils/unzip/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/utils/unzip/Makefile b/utils/unzip/Makefile
index 112b3f4e8..a0d0d14ab 100644
--- a/utils/unzip/Makefile
+++ b/utils/unzip/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unzip
PKG_REV:=60
PKG_VERSION:=6.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)$(PKG_REV).tar.gz
PKG_SOURCE_URL:=@SF/infozip
@@ -44,7 +44,13 @@ endef
define Build/Configure
endef
-TARGET_CFLAGS += -DNO_LCHMOD -DLARGE_FILE_SUPPORT
+TARGET_CFLAGS += \
+ -DNO_LCHMOD \
+ -DLARGE_FILE_SUPPORT \
+ -DUNICODE_WCHAR \
+ -DUNICODE_SUPPORT \
+ -DUTF8_MAYBE_NATIVE \
+ -DZIP64_SUPPORT
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile unzips \
@@ -59,7 +65,10 @@ endef
define Package/unzip/install
$(INSTALL_DIR) $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/{funzip,unzip,unzipsfx,zipgrep} \
+ $(1)/usr/bin/
+ $(LN) unzip $(1)/usr/bin/zipinfo
endef
$(eval $(call BuildPackage,unzip))