aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-07 14:00:25 +0800
committerJeffery To <jeffery.to@gmail.com>2023-08-07 14:00:25 +0800
commitfbc3629ecabb35d9d91eb4fedd8b56b5813a64ec (patch)
tree93202d02cb07760962da57ee01e7de491c36055c
parent19966aadf2a3262d5e455ee23e513c263f1f515e (diff)
python-ifaddr: Update to 0.2.0
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-ifaddr/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/python/python-ifaddr/Makefile b/lang/python/python-ifaddr/Makefile
index 0cdc10717..db9dd4222 100644
--- a/lang/python/python-ifaddr/Makefile
+++ b/lang/python/python-ifaddr/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-ifaddr
-PKG_VERSION:=0.1.7
+PKG_VERSION:=0.2.0
PKG_RELEASE:=1
PYPI_NAME:=ifaddr
-PKG_HASH:=1f9e8a6ca6f16db5a37d3356f07b6e52344f6f9f7e806d618537731669eb1a94
+PKG_HASH:=cc0cbfcaabf765d44595825fb96a99bb12c79716b73b44330ea38ee2b0c4aed4
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=MIT
@@ -26,7 +26,7 @@ define Package/python3-ifaddr
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=Enumerate IP addresses on network adapters
+ TITLE:=Network interface and IP address enumeration library
URL:=https://github.com/pydron/ifaddr
DEPENDS:= \
+python3-light \
@@ -34,7 +34,8 @@ define Package/python3-ifaddr
endef
define Package/python3-ifaddr/description
- ifaddr is a small Python library that allows you to find all the IPv4 and IPv6 addresses of the computer.
+ifaddr is a small Python library that allows you to find all the
+Ethernet and IP addresses of the computer.
endef
$(eval $(call Py3Package,python3-ifaddr))