aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-01-16 08:33:54 +0100
committerSteven Barth <steven@midlink.org>2015-01-16 08:33:54 +0100
commitfa8a8f91e69c82f39763b377379eec3c778f68ad (patch)
treefe366301c9ae2fe06b5013918ce165d7bb687c1e
parenta1bea97f76a1dab2e865d95c0539d8a7c170ad03 (diff)
parent903432c91e48eda6c46bbeab76338b0dba45087a (diff)
Merge pull request #784 from commodo/python-fix-debian
python: add patch to remove Debian/Ubuntu multiarch support
-rw-r--r--lang/python/patches/160-remove-debian-multiarch-support.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/python/patches/160-remove-debian-multiarch-support.patch b/lang/python/patches/160-remove-debian-multiarch-support.patch
new file mode 100644
index 000000000..52d52b94e
--- /dev/null
+++ b/lang/python/patches/160-remove-debian-multiarch-support.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 7868b7b..9ae0ef2 100644
+--- a/setup.py
++++ b/setup.py
+@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ if cross_compiling:
+ self.add_gcc_paths()
+- self.add_multiarch_paths()
+
+ # Add paths specified in the environment variables LDFLAGS and
+ # CPPFLAGS for header and library files.