aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-06-11 16:23:49 +0800
committerJeffery To <jeffery.to@gmail.com>2020-06-11 16:23:49 +0800
commitf9ed65d92247f2ed7eae6a7042dc7020c4bbf484 (patch)
treede91b92ddd6af1ae93e5be848706c5fbb33ae73f
parentf10f1b6c4056bf5714f85456683436de0b2cf36a (diff)
python: Remove references to variants in readme
Build variants are no longer necessary. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/README.md6
1 files changed, 1 insertions, 5 deletions
diff --git a/lang/python/README.md b/lang/python/README.md
index dbd900e6b..46896b912 100644
--- a/lang/python/README.md
+++ b/lang/python/README.md
@@ -128,8 +128,6 @@ All other Python packages (aside from the intepreter) typically use these files:
## Building a Python package
-Packaging for Python uses the `VARIANT` mechanism for packaging inside OpenWrt. (#### FIXME: find a link for this later if it exists)
-
### Include python3-package.mk
Add this after `include $(INCLUDE_DIR)/package.mk`
@@ -189,7 +187,6 @@ define Package/python3-lxml
TITLE:=Pythonic XML processing library
URL:=https://lxml.de
DEPENDS:=+python3-light +libxml2 +libxslt +libexslt
- VARIANT:=python3
endef
define Package/python3-lxml/description
@@ -199,7 +196,6 @@ endef
```
Some considerations here (based on the example above):
-* `VARIANT=python3` must be added
* typically the package is named `Package/python3-<something>` ; this convention makes things easier to follow, though it could work without naming things this way
* `TITLE` can be something a bit more verbose/neat ; typically the name is short as seen above
@@ -334,7 +330,7 @@ endef
### Host-side Python packages for build
-These can be installed via pip and ideally they should only be installed like this, because it's a bit simpler than running them through the OpenWrt build system. Build variants on the host-side build are more complicated (and nearly impossible to do sanely) in the current OpenWrt build system.
+These can be installed via pip and ideally they should only be installed like this, because it's a bit simpler than running them through the OpenWrt build system.
Which is why [for example] if you need python cffi on the host build, it's easier to just add it via:
```