aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2015-03-07 00:10:20 +0100
committerMichael Heimpold <mhei@heimpold.de>2015-03-07 00:10:20 +0100
commitf9aed6ae3f5eefeee80a61018a40d0a601c538fc (patch)
tree2bbc7e5ea134936725a82285ffaf7a72e7e4ac40
parenta05ece16a9037884ce1ed23e9b294ea456b03ff0 (diff)
libugpio: import from oldpackages and upgrade to 0.0.6
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--libs/libugpio/Makefile72
1 files changed, 72 insertions, 0 deletions
diff --git a/libs/libugpio/Makefile b/libs/libugpio/Makefile
new file mode 100644
index 000000000..66168c1e5
--- /dev/null
+++ b/libs/libugpio/Makefile
@@ -0,0 +1,72 @@
+#
+# Copyright (C) 2012-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libugpio
+PKG_VERSION:=0.0.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://github.com/mhei/libugpio/releases/download/v$(PKG_VERSION)
+PKG_MD5SUM:=09c35abbc25f7ebff125bc43ff21ac35
+
+PKG_LICENSE:=LGPL-2.1+
+PKG_LICENSE_FILES:=COPYING.LESSER
+
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libugpio
+ SECTION:=libs
+ CATEGORY:=Libraries
+ URL:=https://github.com/mhei/libugpio
+ TITLE:=Library for using sysfs gpio interface from C programs
+ DEPENDS:=@GPIO_SUPPORT
+endef
+
+define Package/libugpio/description
+ libugpio is a library to ease the use of linux kernel's sysfs
+ gpio interface from C programs and/or other libraries.
+endef
+
+define Package/gpioctl-sysfs
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Tool for controlling gpio pins
+ DEPENDS:=+libugpio
+endef
+
+define Package/gpioctl-sysfs/description
+ Tool for controlling gpio pins using the sysfs api provided by the kernel.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ugpio $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libugpio.{so*,a} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libugpio.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libugpio/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libugpio.so* $(1)/usr/lib/
+endef
+
+define Package/gpioctl-sysfs/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpioctl $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libugpio))
+$(eval $(call BuildPackage,gpioctl-sysfs))