aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-06-03 17:18:36 +0300
committerGitHub <noreply@github.com>2018-06-03 17:18:36 +0300
commitf92312d8b2ace1dc073e329bdfe863b8a918e2ea (patch)
treecfd0c0d56d7305aa561dcc8cc35727a01cadddf3
parent83bbfa42700ab93c067cb41f20332c6bada47362 (diff)
parent75d9ab331ddcd62a91789ad93da16d7c56e55bf6 (diff)
Merge pull request #6063 from cotequeiroz/tdb-symlinks
tdb: avoid installing duplicate files
-rw-r--r--libs/tdb/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/tdb/Makefile b/libs/tdb/Makefile
index db6cd056f..48a88009c 100644
--- a/libs/tdb/Makefile
+++ b/libs/tdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tdb
PKG_VERSION:=1.3.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -83,7 +83,7 @@ endef
define Package/tdb/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
endef