aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-26 13:12:21 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-02-27 08:05:47 +0100
commitf8dcc36af4f2f40076e4d07b1acd1a0177a7dbcb (patch)
treef0303a75e3c0f1200446e108c257b025f25f44d2
parentdc55b0e9413db9a93b08ccd8815de4a158d011ec (diff)
dnsdist: disable XSK to fix the build
XSK support is set to auto by default and on some hosts it is detected as on and leads to: ``` In file included from dnsdist-backend.cc:32: xsk.hh:28:10: fatal error: bits/types/struct_timespec.h: No such file or directory 28 | #include <bits/types/struct_timespec.h> ``` Here we disable XSK so configure will behave more deterministically and hopefully fix the builders. Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/dnsdist/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/dnsdist/Makefile b/net/dnsdist/Makefile
index a669f14df..f61109705 100644
--- a/net/dnsdist/Makefile
+++ b/net/dnsdist/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsdist
PKG_VERSION:=1.9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
@@ -149,6 +149,7 @@ CONFIGURE_ARGS+= \
--with-pic \
--with-lua=luajit \
--with-libcap \
+ --without-xsk \
$(if $(call IsEnabled,DNSDIST_PIE),,--disable-hardening) \
$(if $(call IsEnabled,DNSDIST_SODIUM),--enable-dnscrypt --with-libsodium,--disable-dnscrypt --without-libsodium) \
$(if $(call IsEnabled,DNSDIST_DNSTAP),--enable-dnstap=yes,--enable-dnstap=no) \