aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-16 15:33:42 -0700
committerGitHub <noreply@github.com>2020-06-16 15:33:42 -0700
commitf89c9e89f56039ce914dcbe976f6225fb4b32488 (patch)
treef711efef4d54ffee5c9f95b8c749673bf4da2c9f
parentf30d021087df90e9ed2f5c75076cf06a1a78d781 (diff)
parent5996f762e5495f38a4f49ac42735e1dcf1506835 (diff)
Merge pull request #12525 from neheb/rpp
rp-pppoe: update to 3.14
-rw-r--r--net/rp-pppoe/Makefile20
-rw-r--r--net/rp-pppoe/patches/100-configure.patch36
-rw-r--r--net/rp-pppoe/patches/110-Makefile.patch2
-rw-r--r--net/rp-pppoe/patches/120-use-linux-ether-not-netinet.patch37
-rw-r--r--net/rp-pppoe/patches/130-static-lib-fix.patch6
-rw-r--r--net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch12
6 files changed, 38 insertions, 75 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
index cff70a7a4..e93ebf47a 100644
--- a/net/rp-pppoe/Makefile
+++ b/net/rp-pppoe/Makefile
@@ -8,16 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rp-pppoe
-PKG_VERSION:=3.12
-PKG_RELEASE:=7
-PKG_LICENSE:=LGPL-2.0-or-later
-PKG_CPE_ID:=cpe:/a:roaring_penguin:pppoe
+PKG_VERSION:=3.14
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
-PKG_HASH:=00794e04031546b0e9b8cf286f2a6d1ccfc4a621b2a3abb2d7ef2a7ab7cc86c2
+PKG_SOURCE_URL:=https://dianne.skoll.ca/projects/rp-pppoe/download
+PKG_HASH:=7825232f64ab4d618ef074d62d145ae43d6edc91b9a718c6130a4742bac40e2a
+
+PKG_MAINTAINER:=
+PKG_LICENSE:=LGPL-2.0-or-later
+PKG_LICENSE_FILES:=doc/LICENSE
+PKG_CPE_ID:=cpe:/a:roaring_penguin:pppoe
PKG_BUILD_DEPENDS:=ppp
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -25,7 +29,7 @@ define Package/rp-pppoe/Default
SECTION:=net
CATEGORY:=Network
TITLE:=PPPoE (PPP over Ethernet)
- URL:=http://roaringpenguin.com/products/pppoe
+ URL:=https://dianne.skoll.ca/projects/rp-pppoe/
SUBMENU:=Dial-in/up
endef
@@ -99,7 +103,7 @@ $(call Package/rp-pppoe/Default/description)
This package contains pppoe-sniff.
endef
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent -isystem $(PKG_BUILD_DIR)/missing-headers
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent -isystem $(PKG_BUILD_DIR)/missing-headers -D_BSD_SOURCE
CONFIGURE_PATH := ./src
CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd --enable-plugin=$(STAGING_DIR)/usr/include/
MAKE_FLAGS := DESTDIR="$(PKG_INSTALL_DIR)" PLUGIN_PATH=rp-pppoe.so install
diff --git a/net/rp-pppoe/patches/100-configure.patch b/net/rp-pppoe/patches/100-configure.patch
deleted file mode 100644
index a109c0847..000000000
--- a/net/rp-pppoe/patches/100-configure.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/src/configure
-+++ b/src/configure
-@@ -3691,7 +3691,7 @@ done
-
- for ac_header in linux/if.h
- do :
-- ac_fn_c_check_header_compile "$LINENO" "linux/if.h" "ac_cv_header_linux_if_h" "#include<sys/socket.h>
-+ ac_fn_c_check_header_compile "$LINENO" "linux/if.h" "ac_cv_header_linux_if_h" "#include <sys/socket.h>
- "
- if test "x$ac_cv_header_linux_if_h" = xyes; then :
- cat >>confdefs.h <<_ACEOF
-@@ -3705,10 +3705,11 @@ done
- for ac_header in linux/if_pppox.h
- do :
- ac_fn_c_check_header_compile "$LINENO" "linux/if_pppox.h" "ac_cv_header_linux_if_pppox_h" "
--#include<sys/socket.h>
--#include<net/ethernet.h>
--#include<linux/if.h>
--#include<linux/in.h>
-+#include <sys/socket.h>
-+#include <net/ethernet.h>
-+#include <linux/if.h>
-+#include <linux/in.h>
-+#include <linux/in6.h>
-
- "
- if test "x$ac_cv_header_linux_if_pppox_h" = xyes; then :
-@@ -4644,7 +4645,7 @@ esac
- $as_echo_n "checking packing order of bit fields... " >&6; }
- if test "${rpppoe_cv_pack_bitfields+set}" != set ; then
- if test "$cross_compiling" = yes; then :
-- $ECHO "no defaults for cross-compiling"; exit 0
-+ rpppoe_cv_pack_bitfields="$ac_cv_pack_bitfields"
- else
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
diff --git a/net/rp-pppoe/patches/110-Makefile.patch b/net/rp-pppoe/patches/110-Makefile.patch
index 7b63ddb99..0d4a341f8 100644
--- a/net/rp-pppoe/patches/110-Makefile.patch
+++ b/net/rp-pppoe/patches/110-Makefile.patch
@@ -1,6 +1,6 @@
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -71,7 +71,7 @@ pppoe-sniff: pppoe-sniff.o if.o common.o
+@@ -72,7 +72,7 @@ pppoe-sniff: pppoe-sniff.o if.o common.o
@CC@ -o $@ $^ $(LDFLAGS)
pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@
diff --git a/net/rp-pppoe/patches/120-use-linux-ether-not-netinet.patch b/net/rp-pppoe/patches/120-use-linux-ether-not-netinet.patch
index 8e9185e2c..19dee4881 100644
--- a/net/rp-pppoe/patches/120-use-linux-ether-not-netinet.patch
+++ b/net/rp-pppoe/patches/120-use-linux-ether-not-netinet.patch
@@ -1,34 +1,41 @@
---- a/src/configure
-+++ b/src/configure
-@@ -3676,7 +3676,7 @@ fi
- done
-
-
--for ac_header in fcntl.h sys/dlpi.h sys/ioctl.h sys/time.h syslog.h unistd.h net/if_arp.h netinet/if_ether.h getopt.h sys/uio.h sys/param.h fcntl.h net/bpf.h netpacket/packet.h net/ethernet.h asm/types.h linux/if_packet.h linux/if_ether.h sys/socket.h sys/cdefs.h net/if.h net/if_dl.h net/if_ether.h net/if_types.h netinet/if_ether.h net/if_types.h net/if_dl.h
-+for ac_header in fcntl.h sys/dlpi.h sys/ioctl.h sys/time.h syslog.h unistd.h net/if_arp.h getopt.h sys/uio.h sys/param.h fcntl.h net/bpf.h netpacket/packet.h asm/types.h linux/if_packet.h linux/if_ether.h sys/socket.h sys/cdefs.h net/if.h net/if_dl.h net/if_types.h net/if_types.h net/if_dl.h
- do :
- as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
- ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
--- a/src/if.c
+++ b/src/if.c
-@@ -30,10 +30,6 @@ static char const RCSID[] =
+@@ -33,9 +33,9 @@
#include <linux/if_packet.h>
#endif
-#ifdef HAVE_NET_ETHERNET_H
-#include <net/ethernet.h>
-#endif
--
++//#ifdef HAVE_NET_ETHERNET_H
++//#include <net/ethernet.h>
++//#endif
+
#ifdef HAVE_ASM_TYPES_H
#include <asm/types.h>
- #endif
--- a/src/plugin.c
+++ b/src/plugin.c
-@@ -49,7 +49,6 @@ static char const RCSID[] =
+@@ -52,7 +52,7 @@
#include <unistd.h>
#include <fcntl.h>
#include <signal.h>
-#include <net/ethernet.h>
++//#include <net/ethernet.h>
#include <net/if_arp.h>
#include <linux/ppp_defs.h>
#include <linux/if_pppox.h>
+--- a/src/pppoe.h
++++ b/src/pppoe.h
+@@ -129,9 +129,9 @@ typedef unsigned long UINT32_t;
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+-#ifndef HAVE_SYS_DLPI_H
+-#include <netinet/if_ether.h>
+-#endif
++//#ifndef HAVE_SYS_DLPI_H
++//#include <netinet/if_ether.h>
++//#endif
+ #endif
+
+
diff --git a/net/rp-pppoe/patches/130-static-lib-fix.patch b/net/rp-pppoe/patches/130-static-lib-fix.patch
index c7806dd00..1221c2b4b 100644
--- a/net/rp-pppoe/patches/130-static-lib-fix.patch
+++ b/net/rp-pppoe/patches/130-static-lib-fix.patch
@@ -1,7 +1,7 @@
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -139,7 +139,8 @@ plugin/plugin.o: plugin.c
- @CC@ -DPLUGIN=1 '-DRP_VERSION="$(VERSION)"' $(CFLAGS) -I$(PPPD_INCDIR) -c -o $@ -fPIC $<
+@@ -140,7 +140,8 @@ plugin/plugin.o: plugin.c
+ @CC@ -DPLUGIN=1 '-DRP_VERSION="$(RP_VERSION)"' $(CFLAGS) -I$(PPPD_INCDIR) -c -o $@ -fPIC $<
plugin/libplugin.a: plugin/discovery.o plugin/if.o plugin/common.o plugin/debug.o
- ar -rc $@ $^
@@ -9,4 +9,4 @@
+ @RANLIB@ $@
plugin/discovery.o: discovery.c
- @CC@ -DPLUGIN=1 $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o $@ -fPIC $<
+ @CC@ -DPLUGIN=1 $(CFLAGS) '-DRP_VERSION="$(RP_VERSION)"' -I$(PPPD_INCDIR) -c -o $@ -fPIC $<
diff --git a/net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch b/net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch
deleted file mode 100644
index de3244fdd..000000000
--- a/net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/pppoe.h
-+++ b/src/pppoe.h
-@@ -132,6 +132,9 @@ typedef unsigned long UINT32_t;
- #endif
-
- #include <netinet/in.h>
-+/* avoid redefinitions if <linux/in.h> and <linux/in6.h> get included. */
-+#define _LINUX_IN_H
-+#define _LINUX_IN6_H
-
- #ifdef HAVE_NETINET_IF_ETHER_H
- #include <sys/types.h>