aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Brenken <dev@brenken.org>2022-10-20 11:46:09 +0200
committerDirk Brenken <dev@brenken.org>2022-10-20 11:46:47 +0200
commitf83baf221d11781b1e50b492af2353ad7438d351 (patch)
treeff731003024fac489bae4cbf45be38a789d753be
parenteaed3acdebc3fbf28d4bd435236489ddf819a41b (diff)
adblock: update 4.1.5-2
* fixed broken/blocked oisd download links (switched to the official github mirror) * made sure that curl error out on http errors as well * removed obsolete compatibility stuff from init script Signed-off-by: Dirk Brenken <dev@brenken.org>
-rw-r--r--net/adblock/Makefile2
-rwxr-xr-xnet/adblock/files/adblock.init25
-rwxr-xr-xnet/adblock/files/adblock.sh2
-rw-r--r--net/adblock/files/adblock.sources6
4 files changed, 12 insertions, 23 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index efd049546..e6feeee82 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
PKG_VERSION:=4.1.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock.init b/net/adblock/files/adblock.init
index a7ed06422..732c8a610 100755
--- a/net/adblock/files/adblock.init
+++ b/net/adblock/files/adblock.init
@@ -8,23 +8,12 @@
START=30
USE_PROCD=1
-if [ -n "$(type -t extra_command)" ]; then
- extra_command "suspend" "Suspend adblock processing"
- extra_command "resume" "Resume adblock processing"
- extra_command "query" "<domain> Query active blocklists and backups for a specific domain"
- extra_command "report" "[[<cli>|<mail>|<gen>|<json>] [<top_count>] [<res_count>] [<search>]] Print DNS statistics with an optional search parameter"
- extra_command "list" "[<add>|<add_sha>|<add_utc>|<add_eng>|<add_stb>|<remove>|<remove_sha>|<remove_utc>|<remove_eng>|<remove_stb>] <source(s)> List/Edit available sources"
- extra_command "timer" "[<add> <tasks> <hour> [<minute>] [<weekday>]]|[<remove> <line no.>] List/Edit cron update intervals"
-else
- EXTRA_COMMANDS="status suspend resume query report list timer version"
- EXTRA_HELP=" status Service status
- suspend Suspend adblock processing
- resume Resume adblock processing
- query <domain> Query active blocklists and backups for a specific domain
- report [[<cli>|<mail>|<gen>|<json>] [<count>] [<search>]] Print DNS statistics with an optional search parameter
- list [<add>|<add_sha>|<add_utc>|<add_eng>|<add_stb>|<remove>|<remove_sha>|<remove_utc>|<remove_eng>|<remove_stb>] <source(s)> List/Edit available sources
- timer [<add> <tasks> <hour> [<minute>] [<weekday>]]|[<remove> <line no.>] List/Edit cron update intervals"
-fi
+extra_command "suspend" "Suspend adblock processing"
+extra_command "resume" "Resume adblock processing"
+extra_command "query" "<domain> Query active blocklists and backups for a specific domain"
+extra_command "report" "[[<cli>|<mail>|<gen>|<json>] [<top_count>] [<res_count>] [<search>]] Print DNS statistics with an optional search parameter"
+extra_command "list" "[<add>|<add_sha>|<add_utc>|<add_eng>|<add_stb>|<remove>|<remove_sha>|<remove_utc>|<remove_eng>|<remove_stb>] <source(s)> List/Edit available sources"
+extra_command "timer" "[<add> <tasks> <hour> [<minute>] [<weekday>]]|[<remove> <line no.>] List/Edit cron update intervals"
adb_init="/etc/init.d/adblock"
adb_script="/usr/bin/adblock.sh"
@@ -34,7 +23,7 @@ if [ -s "${adb_pidfile}" ] && { [ "${action}" = "start" ] || [ "${action}" = "st
[ "${action}" = "restart" ] || [ "${action}" = "reload" ] || [ "${action}" = "report" ] ||
[ "${action}" = "suspend" ] || [ "${action}" = "resume" ] || [ "${action}" = "query" ] ||
{ [ "${action}" = "list" ] && [ -n "${1}" ]; }; }; then
- exit 0
+ return 0
fi
boot() {
diff --git a/net/adblock/files/adblock.sh b/net/adblock/files/adblock.sh
index 492edbaa9..f2a962378 100755
--- a/net/adblock/files/adblock.sh
+++ b/net/adblock/files/adblock.sh
@@ -400,7 +400,7 @@ f_fetch() {
;;
"curl")
[ "${adb_fetchinsecure}" = "1" ] && insecure="--insecure"
- adb_fetchparm="${adb_fetchparm:-"${insecure} --connect-timeout 20 --silent --show-error --location -o"}"
+ adb_fetchparm="${adb_fetchparm:-"${insecure} --connect-timeout 20 --fail --silent --show-error --location -o"}"
;;
"uclient-fetch")
[ "${adb_fetchinsecure}" = "1" ] && insecure="--no-check-certificate"
diff --git a/net/adblock/files/adblock.sources b/net/adblock/files/adblock.sources
index 2d69c09d5..4d908249a 100644
--- a/net/adblock/files/adblock.sources
+++ b/net/adblock/files/adblock.sources
@@ -133,21 +133,21 @@
"descurl": "https://github.com/notracking/hosts-blocklists"
},
"oisd_basic": {
- "url": "https://dblw.oisd.nl/basic/",
+ "url": "https://raw.githubusercontent.com/sjhgvr/oisd/main/dblw_basic.txt",
"rule": "/^\\*\\.([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
"size": "L",
"focus": "general",
"descurl": "https://oisd.nl"
},
"oisd_nsfw": {
- "url": "https://dblw.oisd.nl/nsfw/",
+ "url": "https://raw.githubusercontent.com/sjhgvr/oisd/main/dblw_nsfw.txt",
"rule": "/^\\*\\.([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
"size": "XL",
"focus": "general",
"descurl": "https://oisd.nl"
},
"oisd_full": {
- "url": "https://dblw.oisd.nl",
+ "url": "https://raw.githubusercontent.com/sjhgvr/oisd/main/dblw_full.txt",
"rule": "/^\\*\\.([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
"size": "XXL",
"focus": "general",