aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-21 15:12:04 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-21 15:15:53 -0700
commitf7e7ee5ff3cafb440465c03bd746f306d8597c4b (patch)
tree45fdd66fefd7145957c5260cbe47efedf43d0fdc
parent51199dee15b3a36acd471c9a925c2219737a2d47 (diff)
squid: Update to 4.6
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/squid/Makefile6
-rw-r--r--net/squid/patches/001-cross_compile.patch2
-rw-r--r--net/squid/patches/010-openssl-engine.patch11
3 files changed, 4 insertions, 15 deletions
diff --git a/net/squid/Makefile b/net/squid/Makefile
index bd56d067f..008ad4b3b 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=squid
-PKG_VERSION:=4.4
-PKG_RELEASE:=3
+PKG_VERSION:=4.6
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
@@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
http://www2.pl.squid-cache.org/Versions/v4/ \
http://www.squid-cache.org/Versions/v4/
-PKG_HASH:=4905e6da7f5574d2583ba36f398bb062a12d51e70d67035078b6e85b09e9ee82
+PKG_HASH:=015bade5d3a4905142c4c605df5c4216471e3d8338079955e0e44b0ae0303d41
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/net/squid/patches/001-cross_compile.patch b/net/squid/patches/001-cross_compile.patch
index 6b2ed9f2b..e392dba71 100644
--- a/net/squid/patches/001-cross_compile.patch
+++ b/net/squid/patches/001-cross_compile.patch
@@ -10,7 +10,7 @@ Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -8383,7 +8383,8 @@
+@@ -8385,7 +8385,8 @@
# cf_gen builds the configuration files.
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
diff --git a/net/squid/patches/010-openssl-engine.patch b/net/squid/patches/010-openssl-engine.patch
deleted file mode 100644
index e7f97eec5..000000000
--- a/net/squid/patches/010-openssl-engine.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/ssl/support.cc
-+++ b/src/ssl/support.cc
-@@ -485,7 +485,7 @@ Ssl::Initialize(void)
-
- SQUID_OPENSSL_init_ssl();
-
--#if HAVE_OPENSSL_ENGINE_H
-+#ifndef OPENSSL_NO_ENGINE
- if (::Config.SSL.ssl_engine) {
- ENGINE_load_builtin_engines();
- ENGINE *e;