aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2020-07-29 10:17:14 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2020-07-30 10:02:13 +0800
commitf69f4f3fae71a142e8133f4bd05cd1c78b429a95 (patch)
treec842ac94b5edd7e8423890073e133c574d28b435
parentacca35d460e9c8dfca369641fcee0f41e8cd259d (diff)
openvswitch: rename shared var name ovs{,_}_common_depends
To avoid conflict with package ovs_common_depends of package openvswitch-common Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
-rw-r--r--net/openvswitch/Makefile2
-rw-r--r--net/openvswitch/openvswitch.mk4
-rw-r--r--net/ovn/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 2a9f34227..74a0ae22c 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -156,7 +156,7 @@ ovs_kmod_openvswitch-lisp-intree_depends:= +kmod-openvswitch-intree
ovs_kmod_openvswitch-lisp-intree_files:= $(ovs_kmod_intree_dir)/vport-lisp.ko
$(eval $(call OvsKmodPackageTemplate,openvswitch-lisp-intree))
-ovs_common_depends:= +libatomic +libunbound +libunwind
+ovs__common_depends:= +libatomic +libunbound +libunwind
# Dependency review
#
diff --git a/net/openvswitch/openvswitch.mk b/net/openvswitch/openvswitch.mk
index cf46f6be1..78d35c031 100644
--- a/net/openvswitch/openvswitch.mk
+++ b/net/openvswitch/openvswitch.mk
@@ -10,7 +10,7 @@ ovs_builddir=$(KERNEL_BUILD_DIR)/openvswitch-$(ovs_version)
# Shared vars, macros
-ovs_common_depends:=
+ovs__common_depends:=
ovs_packages:=
ovs_package_name=$(if $(filter openvswitch,$(1)),openvswitch,openvswitch-$(1))
@@ -22,7 +22,7 @@ define OvsPackageTemplate
URL:=https://www.openvswitch.org
TITLE:=$(ovs_$(1)_title)
HIDDEN:=$(ovs_$(1)_hidden)
- DEPENDS:=$(ovs_$(1)_depends) $(ovs_common_depends)
+ DEPENDS:=$(ovs_$(1)_depends) $(ovs__common_depends)
endef
define Package/$(call ovs_package_name,$(1))/install
diff --git a/net/ovn/Makefile b/net/ovn/Makefile
index 252158fc0..fa7ed552d 100644
--- a/net/ovn/Makefile
+++ b/net/ovn/Makefile
@@ -33,7 +33,7 @@ PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-host.mk
-ovs_common_depends:= +libatomic +libunbound
+ovs__common_depends:= +libatomic +libunbound
ovs_libovn_title:=Open vSwitch (libovn.so)
ovs_libovn_hidden:=1