aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-16 18:11:12 -0400
committerSteven Barth <steven@midlink.org>2014-07-19 14:08:11 +0200
commitf602822173d516e69e92487025e5407066fa0c03 (patch)
treeaf05dbacb3587ad1624224b2b8d0bc749ec340ae
parent8c95cf3a126061b8df495efde56c43143e326c2a (diff)
Copy libexif package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--libs/libexif/Makefile60
-rw-r--r--libs/libexif/patches/100-no_doc.patch11
2 files changed, 71 insertions, 0 deletions
diff --git a/libs/libexif/Makefile b/libs/libexif/Makefile
new file mode 100644
index 000000000..89ed3dc98
--- /dev/null
+++ b/libs/libexif/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libexif
+PKG_VERSION:=0.6.19
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/libexif
+PKG_MD5SUM:=56144a030a4c875c600b1ccf713f69f7
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libexif
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=library for jpeg files with exif tags
+ URL:=http://libexif.sourceforge.net/
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+endef
+
+define Package/libexif/description
+ libexif is a library for parsing, editing, and saving EXIF data. It is
+ intended to replace lots of redundant implementations in command-line
+ utilities and programs with GUIs.
+endef
+
+CONFIGURE_ARGS+= \
+ --enable-shared \
+ --enable-static \
+ --disable-rpath \
+ --without-libiconv-prefix \
+ --without-libintl-prefix \
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libexif $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexif*.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libexif.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libexif/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexif*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libexif))
diff --git a/libs/libexif/patches/100-no_doc.patch b/libs/libexif/patches/100-no_doc.patch
new file mode 100644
index 000000000..5ca00ce62
--- /dev/null
+++ b/libs/libexif/patches/100-no_doc.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -280,7 +280,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = m4m po libexif test doc binary contrib
++SUBDIRS = m4m po libexif test binary contrib
+ @SHIP_BINARIES_TRUE@README_W32_XDIST = README-Win32.txt
+ EXTRA_DIST = @PACKAGE_TARNAME@.spec $(README_W32_XDIST) libexif.pc.in \
+ libexif-uninstalled.pc.in