aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-09 22:44:43 +0200
committerRosen Penev <rosenp@gmail.com>2024-02-10 14:54:24 -0800
commitf58be51721fb0e2c5aa0747bce36a19deb7392dd (patch)
tree2719d87f213f92b8ae2e5bb32b8cfd016a7f0ca0
parent496baecb26b532b6ccc97d082092736bb340ec92 (diff)
squid: fix configure options
- Remove non-existing 'dlmalloc' option - Use 'with-cap' instead of 'with-libcap' - Use 'with-xml2' instead of 'with-libxml2' - Patch configure.ac to properly handle 'with-nettle' Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/squid/Config.in5
-rw-r--r--net/squid/Makefile7
-rw-r--r--net/squid/patches/020-fix-nettle-configure.patch11
3 files changed, 14 insertions, 9 deletions
diff --git a/net/squid/Config.in b/net/squid/Config.in
index 872526e12..5c8901ef8 100644
--- a/net/squid/Config.in
+++ b/net/squid/Config.in
@@ -18,10 +18,6 @@ if PACKAGE_squid
bool "Enable ICAP client support"
default n
- config SQUID_enable-dlmalloc
- bool "Compile & use the malloc package by Doug Lea"
- default y
-
config SQUID_enable-ssl-crtd
bool "Enable dynamic SSL certificate generation"
depends on !SQUID_use-gnutls
@@ -92,4 +88,3 @@ if PACKAGE_squid
comment "Additional tools"
endif
-
diff --git a/net/squid/Makefile b/net/squid/Makefile
index 205791185..03fe5ee3b 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=squid
PKG_VERSION:=6.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www2.pl.squid-cache.org/Versions/v6/ \
@@ -91,7 +91,6 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_SQUID_auth-digest),--enable,--disable)-auth-digest \
$(if $(CONFIG_SQUID_auth-ntlm),--enable,--disable)-auth-ntlm \
$(if $(CONFIG_SQUID_auth-negotiate),--enable,--disable)-auth-negotiate \
- $(if $(CONFIG_SQUID_enable-ipv6),--enable,--disable)-dlmalloc \
$(if $(CONFIG_SQUID_enable-ipv6),--enable,--disable)-ipv6 \
$(if $(CONFIG_SQUID_enable-ssl-crtd),--enable-ssl-crtd) \
$(if $(CONFIG_SQUID_use-gnutls),--with,--without)-gnutls \
@@ -100,10 +99,10 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_SQUID_enable-icmp),--enable,--disable)-icmp \
$(if $(CONFIG_SQUID_enable-icap-client),--enable,--disable)-icap-client \
$(if $(CONFIG_SQUID_enable-snmp),--enable,--disable)-snmp \
- $(if $(CONFIG_SQUID_with-libcap),--with,--without)-libcap \
+ $(if $(CONFIG_SQUID_with-libcap),--with,--without)-cap \
$(if $(CONFIG_SQUID_with-nettle),--with,--without)-nettle \
$(if $(CONFIG_SQUID_with-expat),--with,--without)-expat \
- $(if $(CONFIG_SQUID_with-libxml2),--with,--without)-libxml2
+ $(if $(CONFIG_SQUID_with-libxml2),--with,--without)-xml2
CONFIGURE_VARS += \
ac_cv_header_linux_netfilter_ipv4_h=yes \
diff --git a/net/squid/patches/020-fix-nettle-configure.patch b/net/squid/patches/020-fix-nettle-configure.patch
new file mode 100644
index 000000000..222994a04
--- /dev/null
+++ b/net/squid/patches/020-fix-nettle-configure.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1043,7 +1043,7 @@ AC_MSG_NOTICE([HTCP support enabled: $en
+
+ # Cryptograhic libraries
+ SQUID_AUTO_LIB(nettle,[Nettle crypto],[LIBNETTLE])
+-AS_IF(test "x$with_nettle" != "xno"],[
++AS_IF([test "x$with_nettle" != "xno"],[
+ SQUID_STATE_SAVE(squid_nettle_state)
+ PKG_CHECK_MODULES([LIBNETTLE],[nettle >= 3.4],[],[
+ CPPFLAGS="$LIBNETTLE_CFLAGS $CPPFLAGS"