aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-04-18 18:21:29 -0600
committerRosen Penev <rosenp@gmail.com>2023-05-01 13:36:25 +0300
commitf544e950999b8c7502f1c7674c6dfdb8a701c140 (patch)
treeb114bbf30600a8683ba07e5b7566a92b18ece73e
parent2fed4c089598b38d86531087fc41782f27c23c26 (diff)
kea: Update to 2.2.0
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
-rw-r--r--net/kea/Makefile8
-rw-r--r--net/kea/patches/003-no-test-compile.patch12
-rw-r--r--net/kea/patches/004-replace-rev-with-awk.patch2
-rw-r--r--net/kea/patches/010-openssl-deprecated.patch2
4 files changed, 8 insertions, 16 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index f269b4141..1febb3046 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kea
-PKG_VERSION:=2.0.3
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
-PKG_HASH:=d642907374d17480ebe4df805b363dc9e230a955475a9f3e04a076b52d5c43ec
+PKG_HASH:=da7d90ca62a772602dac6e77e507319038422895ad68eeb142f1487d67d531d2
-PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@rosinson.com>
+PKG_MAINTAINER:=BangLang Huang <banglang.huang@foxmail.com>, Rosy Song <rosysong@rosinson.com>
PKG_LICENSE:=MPL-2.0
PKG_LICENSE_FILES:=COPYING
diff --git a/net/kea/patches/003-no-test-compile.patch b/net/kea/patches/003-no-test-compile.patch
index 132c942aa..709e534c6 100644
--- a/net/kea/patches/003-no-test-compile.patch
+++ b/net/kea/patches/003-no-test-compile.patch
@@ -158,14 +158,6 @@
AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
AM_CPPFLAGS += $(BOOST_INCLUDES)
---- a/src/lib/cql/Makefile.am
-+++ b/src/lib/cql/Makefile.am
-@@ -1,4 +1,4 @@
--SUBDIRS = . testutils tests
-+SUBDIRS = .
-
- AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
- AM_CPPFLAGS += $(BOOST_INCLUDES) $(CQL_CPPFLAGS)
--- a/src/lib/cryptolink/Makefile.am
+++ b/src/lib/cryptolink/Makefile.am
@@ -1,4 +1,4 @@
@@ -203,8 +195,8 @@
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = subdir-objects
--SUBDIRS = . testutils tests benchmarks
-+SUBDIRS = . benchmarks
+-SUBDIRS = . testutils tests
++SUBDIRS = .
# DATA_DIR is the directory where to put default CSV files and the DHCPv6
# server ID file (i.e. the file where the server finds its DUID at startup).
diff --git a/net/kea/patches/004-replace-rev-with-awk.patch b/net/kea/patches/004-replace-rev-with-awk.patch
index d22dcd4b0..db22903c0 100644
--- a/net/kea/patches/004-replace-rev-with-awk.patch
+++ b/net/kea/patches/004-replace-rev-with-awk.patch
@@ -1,6 +1,6 @@
--- a/src/bin/keactrl/keactrl.in
+++ b/src/bin/keactrl/keactrl.in
-@@ -117,7 +117,7 @@ get_pid_from_file() {
+@@ -115,7 +115,7 @@ get_pid_from_file() {
# Extract the name portion (from last slash to last dot) of the config file name
# File name and extension are documented in src/lib/util/filename.h
local conf_name
diff --git a/net/kea/patches/010-openssl-deprecated.patch b/net/kea/patches/010-openssl-deprecated.patch
index c8b438efc..6487b0a44 100644
--- a/net/kea/patches/010-openssl-deprecated.patch
+++ b/net/kea/patches/010-openssl-deprecated.patch
@@ -1,6 +1,6 @@
--- a/src/lib/cryptolink/openssl_link.cc
+++ b/src/lib/cryptolink/openssl_link.cc
-@@ -79,7 +79,7 @@ CryptoLink::initialize() {
+@@ -77,7 +77,7 @@ CryptoLink::initialize(CryptoLink& c) {
std::string
CryptoLink::getVersion() {