aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-26 13:21:17 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-28 22:30:11 -0300
commitf434a33a13454d09fcc287477193b4626c387deb (patch)
tree98a1ddaa2d53953d151a51c2bcc4e2d97c1aef5d
parent26fd0cbac936573dfb984bc721cddd46417d64f3 (diff)
php7-pecl-imagick: configure --with-imagick=...
Add --with-imagick=$(STAGING_DIR)/usr so that configure picks MagickWand-config from there, before it finds an eventual host-installed version. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
-rw-r--r--lang/php7-pecl-imagick/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/php7-pecl-imagick/Makefile b/lang/php7-pecl-imagick/Makefile
index 4582e9373..3036db997 100644
--- a/lang/php7-pecl-imagick/Makefile
+++ b/lang/php7-pecl-imagick/Makefile
@@ -9,7 +9,7 @@ PECL_NAME:=imagick
PECL_LONGNAME:=Image Processing (ImageMagick binding)
PKG_VERSION:=3.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_HASH:=8dd5aa16465c218651fc8993e1faecd982e6a597870fd4b937e9ece02d567077
PKG_NAME:=php7-pecl-imagick
@@ -29,5 +29,7 @@ include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include ../php7/pecl.mk
+CONFIGURE_ARGS+= --with-imagick="$(STAGING_DIR)/usr"
+
$(eval $(call PHP7PECLPackage,imagick,$(PECL_LONGNAME),+imagemagick,30))
$(eval $(call BuildPackage,$(PKG_NAME)))