aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-18 13:10:10 -0700
committerGitHub <noreply@github.com>2020-08-18 13:10:10 -0700
commitf3bb00dfc2fbf2d60e598c9c9ed8ea6ddf19e0be (patch)
tree8a383adc04ab375c89fc91bcd68380e6e02b7a0c
parent00571c397b61868f426e2292f1c7494788815f07 (diff)
parent932b850245b3688b01304a0adb8847e0d6757eb3 (diff)
Merge pull request #13159 from neheb/sed
sed: don't use selinux
-rw-r--r--utils/sed/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/utils/sed/Makefile b/utils/sed/Makefile
index 50b35de3c..d7e1461ee 100644
--- a/utils/sed/Makefile
+++ b/utils/sed/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sed
PKG_VERSION:=4.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/sed
@@ -42,11 +42,13 @@ extracting part of a file using pattern matching or substituting multiple
occurrences of a string within a file.
endef
+CONFIGURE_ARGS += \
+ --disable-acl \
+ --without-selinux
+
define Package/sed/install
$(INSTALL_DIR) $(1)/usr/libexec
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sed $(1)/usr/libexec/sed-gnu
endef
-CONFIGURE_ARGS+= --disable-acl
-
$(eval $(call BuildPackage,sed))