aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-25 01:13:17 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-31 16:14:08 +0800
commitf279ae9418fff4f83bd16b353ef008e548d82cd7 (patch)
tree883e65cb77f29a3ec2a6dde3c4d1f50bd70dae6b
parent8c7709b911df9f85189a9c71cfc196702f4cb338 (diff)
python-sentry-sdk: Update to 1.29.2, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
1 files changed, 6 insertions, 7 deletions
diff --git a/lang/python/python-sentry-sdk/Makefile b/lang/python/python-sentry-sdk/Makefile
index 81854826b..748d73432 100644
--- a/lang/python/python-sentry-sdk/Makefile
+++ b/lang/python/python-sentry-sdk/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-sentry-sdk
-PKG_VERSION:=1.5.4
+PKG_VERSION:=1.29.2
PKG_RELEASE:=1
PYPI_NAME:=sentry-sdk
-PKG_HASH:=f7e54567937ebcbe938c4df1075ec891587faeb7c74184b88cf2894e47c86116
+PKG_HASH:=a99ee105384788c3f228726a88baf515fe7b5f1d2d0f215a03d194369f158df7
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
-PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
include ../pypi.mk
@@ -26,17 +26,16 @@ define Package/python3-sentry-sdk
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=Python Client for Sentry
+ TITLE:=Client for Sentry
URL:=https://github.com/getsentry/sentry-python
DEPENDS:= \
+ +python3 \
+python3-certifi \
- +python3-light \
- +python3-logging \
+python3-urllib3
endef
define Package/python3-sentry-sdk/description
- Python Sentry-Python is an SDK for Sentry.
+This is the official Python SDK for Sentry.
endef
$(eval $(call Py3Package,python3-sentry-sdk))