aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-01-22 09:09:48 +0100
committerGitHub <noreply@github.com>2021-01-22 09:09:48 +0100
commitf21885ec850c98d92113ffdbf3e2f314aeb14c3b (patch)
treed50672025a94654e910e0cea78d46c0e1a84abc2
parentf31c937e94e4635b49dc61d95ead8cc466660263 (diff)
parent9eab8cceda7640a751dce82ec7d7547b0d1e1ed6 (diff)
Merge pull request #14510 from zhanhb/ddns-scripts
ddns-scripts: fix wget-ssl path
-rw-r--r--net/ddns-scripts/Makefile2
-rw-r--r--net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh7
2 files changed, 5 insertions, 4 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index d3744c871..04a7e8c8f 100644
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
PKG_VERSION:=2.8.2
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_LICENSE:=GPL-2.0
diff --git a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
index eeb212ec1..141547f30 100644
--- a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
@@ -85,7 +85,8 @@ NSLOOKUP=$(command -v nslookup)
# Transfer Programs
WGET=$(command -v wget)
-WGET_SSL=$(command -v wget-ssl)
+# SSL support is available if WGET_SSL is not empty
+WGET_SSL=$("$WGET" -V 2>/dev/null | grep -F +https)
CURL=$(command -v curl)
# CURL_SSL not empty then SSL support available
@@ -711,8 +712,8 @@ do_transfer() {
[ -z "$bind_network" ] && [ "$ip_source" = "network" ] && [ "$ip_network" ] && bind_network="$ip_network"
# lets prefer GNU Wget because it does all for us - IPv4/IPv6/HTTPS/PROXY/force IP version
- if [ -n "$WGET_SSL" -a $USE_CURL -eq 0 ]; then # except global option use_curl is set to "1"
- __PROG="$WGET_SSL --hsts-file=/tmp/.wget-hsts -nv -t 1 -O $DATFILE -o $ERRFILE" # non_verbose no_retry outfile errfile
+ if [ -n "$WGET_SSL" ] && [ $USE_CURL -eq 0 ]; then # except global option use_curl is set to "1"
+ __PROG="$WGET --hsts-file=/tmp/.wget-hsts -nv -t 1 -O $DATFILE -o $ERRFILE" # non_verbose no_retry outfile errfile
# force network/ip to use for communication
if [ -n "$bind_network" ]; then
local __BINDIP