aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 14:43:07 +0800
committerTianling Shen <cnsztl@gmail.com>2023-05-18 19:24:24 +0800
commitf20ba7f6ed0df1fbd94b29045c627b586007efa7 (patch)
tree82b57b56b92991eb35a52066a0c3674f70d224b0
parentb84d35f57798d61d74dd7d123aa58f1af0db91b6 (diff)
mariadb: fix compilation with musl 1.2.4
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so just having _GNU_SOURCE defined is not enough anymore. Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
1 files changed, 5 insertions, 1 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index cf9c26666..5c4d6e7f2 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mariadb
PKG_VERSION:=10.9.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL := https://archive.mariadb.org/$(PKG_NAME)-$(PKG_VERSION)/source
@@ -178,6 +178,10 @@ MARIADB_COMMON_DEPENDS := \
# ignore them.
TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
+ifneq ($(CONFIG_USE_MUSL),)
+ TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
+endif
+
define Package/mariadb/disable/engine
echo > $(1)/storage/$(2)/CMakeLists.txt
endef