aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Goodman <aaronjg@stanford.edu>2020-11-13 13:08:14 -0500
committerAaron Goodman <aaronjg@stanford.edu>2020-11-16 11:23:10 -0500
commitf014a7f5420aaf706c046394f51200faad7fbd88 (patch)
tree2d2edb2da34f80e8ebdb7764ca29a02b428bb3a7
parenta5f3e6bb6be8e7c0e9dd5be0b7e2387d7354c96c (diff)
mwan3: don't trigger rpcd install hooks if rpcd not installed
Signed-off-by: Aaron Goodman <aaronjg@stanford.edu>
-rw-r--r--net/mwan3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index ec782a089..ecdd06f96 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -45,7 +45,7 @@ endef
define Package/mwan3/postinst
#!/bin/sh
-if [ -z "$${IPKG_INSTROOT}" ]; then
+if [ -z "$${IPKG_INSTROOT}" ] && [ -x /etc/init.d/rpcd ]; then
/etc/init.d/rpcd restart
fi
exit 0
@@ -53,7 +53,7 @@ endef
define Package/mwan3/postrm
#!/bin/sh
-if [ -z "$${IPKG_INSTROOT}" ]; then
+if [ -z "$${IPKG_INSTROOT}" ] && [ -x /etc/init.d/rpcd ]; then
/etc/init.d/rpcd restart
fi
exit 0