aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-18 21:43:47 -0700
committerGitHub <noreply@github.com>2020-09-18 21:43:47 -0700
commitefe525033d078432c6031c533ece1a90c0916cc5 (patch)
tree8b5fe135435825ba65f060a36be97110a9d3d957
parent50cced2475063556b777c7f9b2092bbe458f4492 (diff)
parent885c054d57592843aa066a8b63bae10446b29c8c (diff)
Merge pull request #13417 from RussellSenior/atftp-add-init-script
atftp: add init script and config file for atftpd
-rw-r--r--net/atftp/Makefile7
-rw-r--r--net/atftp/files/atftpd.conf3
-rwxr-xr-xnet/atftp/files/atftpd.init17
-rw-r--r--net/atftp/test.sh3
4 files changed, 29 insertions, 1 deletions
diff --git a/net/atftp/Makefile b/net/atftp/Makefile
index 72362c604..5f1d43401 100644
--- a/net/atftp/Makefile
+++ b/net/atftp/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=atftp
PKG_VERSION:=0.7.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -53,6 +53,11 @@ endef
define Package/atftpd/install
$(INSTALL_DIR) $(1)/etc
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/atftpd.init $(1)/etc/init.d/atftpd
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_BIN) ./files/atftpd.conf $(1)/etc/config/atftpd
+ $(INSTALL_DIR) $(1)/srv/tftp
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)//usr/sbin/atftpd $(1)/usr/sbin/
endef
diff --git a/net/atftp/files/atftpd.conf b/net/atftp/files/atftpd.conf
new file mode 100644
index 000000000..6bd66e94c
--- /dev/null
+++ b/net/atftp/files/atftpd.conf
@@ -0,0 +1,3 @@
+
+config service 'service'
+ option path '/srv/tftp'
diff --git a/net/atftp/files/atftpd.init b/net/atftp/files/atftpd.init
new file mode 100755
index 000000000..83573f998
--- /dev/null
+++ b/net/atftp/files/atftpd.init
@@ -0,0 +1,17 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2020 OpenWrt.org
+
+START=95
+PIDFILE=/tmp/run/atftpd.pid
+
+start() {
+ config_load atftpd
+ config_get SRV service path "/srv/tftp"
+ config_get PORT service port 69
+
+ atftpd --pidfile $PIDFILE --user root.root --port $PORT --daemon $SRV
+}
+
+stop() {
+ kill $(cat $PIDFILE)
+}
diff --git a/net/atftp/test.sh b/net/atftp/test.sh
new file mode 100644
index 000000000..68054b7b8
--- /dev/null
+++ b/net/atftp/test.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+"$1" --version 2>&1 | grep "$2"