aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-04-06 11:39:28 +0200
committerFlorian Eckert <fe@dev.tdt.de>2022-04-06 17:31:58 +0200
commiteed4277d5cc923c41ae2c4e182fc7449bb44b090 (patch)
tree102a9890aa1f79acde869f28204277bf230eea11
parent209bcc649ad0f74534a4d288849180c9119380a1 (diff)
keepalived: fix libip6tc dependency
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--net/keepalived/Config.in10
-rw-r--r--net/keepalived/Makefile2
2 files changed, 11 insertions, 1 deletions
diff --git a/net/keepalived/Config.in b/net/keepalived/Config.in
index 862398db1..33321aa87 100644
--- a/net/keepalived/Config.in
+++ b/net/keepalived/Config.in
@@ -66,11 +66,21 @@ config KEEPALIVED_IPTABLES
depends on KEEPALIVED_VRRP
bool
default y
+ select KEEPALIVED_IP6TABLES
prompt "Enable iptables for VIP filtering"
help
Builds support for using iptables/ipsets for filtering packets
to VIPs
+config KEEPALIVED_IP6TABLES
+ depends on KEEPALIVED_VRRP && KEEPALIVED_IPTABLES && IPV6
+ bool
+ default y
+ prompt "Enable ip6tables for VIP filtering"
+ help
+ Builds support for using ip6tables/ipsets for filtering packets
+ to VIPs
+
config KEEPALIVED_NFTABLES
depends on KEEPALIVED_VRRP
bool
diff --git a/net/keepalived/Makefile b/net/keepalived/Makefile
index ce1afd233..3665df834 100644
--- a/net/keepalived/Makefile
+++ b/net/keepalived/Makefile
@@ -64,7 +64,7 @@ define Package/keepalived
+KEEPALIVED_VRRP:libnfnetlink \
+KEEPALIVED_SHA1:libopenssl \
+KEEPALIVED_IPTABLES:libip4tc \
- +(KEEPALIVED_IPTABLES&&IPV6):libip6tc \
+ +KEEPALIVED_IP6TABLES:libip6tc \
+KEEPALIVED_IPTABLES:libxtables \
+KEEPALIVED_IPTABLES:libipset \
+(KEEPALIVED_SNMP_VRRP||KEEPALIVED_SNMP_CHECKER||KEEPALIVED_SNMP_RFC2||KEEPALIVED_SNMP_RFC3):libnetsnmp \