aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-27 12:01:45 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-27 12:01:45 -0700
commitee4a1c0c096323c7759cdf55b664a8bccf99b3e4 (patch)
treef4e9b2ce7972cbaa634673015329ac30a17687e7
parent4bc2371a3f7f5ffeb34af04ddb84cb1468da8f91 (diff)
miniupnpd: Fix compilation under glibc
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/miniupnpd/Makefile2
-rw-r--r--net/miniupnpd/patches/200-remove-default-cflags.patch9
2 files changed, 4 insertions, 7 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index be7f4343e..822a297da 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd
PKG_VERSION:=2.1.20190408
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/miniupnpd/patches/200-remove-default-cflags.patch b/net/miniupnpd/patches/200-remove-default-cflags.patch
index 9efa8bb35..8ee8bf950 100644
--- a/net/miniupnpd/patches/200-remove-default-cflags.patch
+++ b/net/miniupnpd/patches/200-remove-default-cflags.patch
@@ -8,16 +8,13 @@
-CFLAGS += -fno-common
-CFLAGS += -fstack-protector -fPIE
-CFLAGS += -D_FORTIFY_SOURCE=2
--CPPFLAGS += -D_GNU_SOURCE
--CFLAGS += -Wall
--CFLAGS += -Wextra -Wstrict-prototypes -Wdeclaration-after-statement
+#CFLAGS += -fno-strict-aliasing
+#CFLAGS += -fno-common
+#CFLAGS += -fstack-protector -fPIE
+#CFLAGS += -D_FORTIFY_SOURCE=2
-+#CPPFLAGS += -D_GNU_SOURCE
-+#CFLAGS += -Wall
-+#CFLAGS += -Wextra -Wstrict-prototypes -Wdeclaration-after-statement
+ CPPFLAGS += -D_GNU_SOURCE
+ CFLAGS += -Wall
+ CFLAGS += -Wextra -Wstrict-prototypes -Wdeclaration-after-statement
#CFLAGS += -Wno-missing-field-initializers
#CFLAGS += -ansi # iptables headers does use typeof which is a gcc extension
-LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie