aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-22 16:27:35 -0700
committerGitHub <noreply@github.com>2020-09-22 16:27:35 -0700
commited39c2f02e1f05c40161986c6d0581f7eba58bea (patch)
treec2c10617102837c5f55a8ed72fc424cbdb51bb36
parent3a32eec211df79ecb33b38fa2ec500261670bb63 (diff)
parent65f4f80d106a4df25616b5c7f2dfbd52f07b1de0 (diff)
Merge pull request #13461 from neheb/mpd
mpd: update to 0.21.26
-rw-r--r--sound/mpd/Makefile6
-rw-r--r--sound/mpd/patches/010-iconv.patch8
2 files changed, 7 insertions, 7 deletions
diff --git a/sound/mpd/Makefile b/sound/mpd/Makefile
index be62a1dc2..b0700875e 100644
--- a/sound/mpd/Makefile
+++ b/sound/mpd/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mpd
-PKG_VERSION:=0.21.25
-PKG_RELEASE:=5
+PKG_VERSION:=0.21.26
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.21/
-PKG_HASH:=20a0ad01bf327b2dbeb6ae8e1af952cb0de83d2d63fab0fa4b7183a74765c201
+PKG_HASH:=f9e68221c7a6829ec02f281eb313b2f24182020f5eb65ab22b337e6169ea4eea
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later
diff --git a/sound/mpd/patches/010-iconv.patch b/sound/mpd/patches/010-iconv.patch
index 81adf1ba7..d589db30e 100644
--- a/sound/mpd/patches/010-iconv.patch
+++ b/sound/mpd/patches/010-iconv.patch
@@ -1,4 +1,4 @@
-From 90fcdb5b02e08b3faf2e321b081798cc18d35b15 Mon Sep 17 00:00:00 2001
+From 8ece1141e455d6643df0be885a5df200bdb3bc78 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Thu, 30 Jul 2020 14:34:07 -0700
Subject: [PATCH] icu/meson: link against iconv when used externally
@@ -17,18 +17,18 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/src/lib/icu/meson.build b/src/lib/icu/meson.build
-index bd6e30944..132e15b89 100644
+index bd6e30944..e63d614a0 100644
--- a/src/lib/icu/meson.build
+++ b/src/lib/icu/meson.build
@@ -18,8 +18,18 @@ if icu_dep.found()
'Init.cxx',
]
elif not get_option('iconv').disabled()
-- have_iconv = compiler.has_function('iconv')
+- have_iconv = compiler.has_function('iconv', prefix : '#include <iconv.h>')
- conf.set('HAVE_ICONV', have_iconv)
+ have_iconv = c_compiler.has_header_symbol('iconv.h', 'iconv')
+ if have_iconv
-+ libiconv = c_compiler.find_library('iconv')
++ libiconv = c_compiler.find_library('iconv', required : false)
+ conf.set('HAVE_ICONV', have_iconv)
+ libiconv_dep = static_library('iconv', icu_sources, include_directories: inc, dependencies: libiconv)
+ icu_dep = declare_dependency(link_with: libiconv_dep, dependencies: util_dep)