aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-01-03 19:01:05 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-01-03 19:05:14 +0100
commitec2d4aeebd8ee7140f359abb7e4832163d943e0a (patch)
tree92985a887aadd05598bc0380fc48eae8af6f09c5
parent33c5c14c528c01bf390df0a599a585187182857d (diff)
gnutls: corrected compilation of tools when OCSP is disabled
Resolves #640
-rw-r--r--libs/gnutls/Makefile2
-rw-r--r--libs/gnutls/patches/002-ocsp-in-tools.patch51
2 files changed, 52 insertions, 1 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index 2e7cd6eaf..eb6ce944a 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
PKG_VERSION:=3.3.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/libs/gnutls/patches/002-ocsp-in-tools.patch b/libs/gnutls/patches/002-ocsp-in-tools.patch
new file mode 100644
index 000000000..94008e4e2
--- /dev/null
+++ b/libs/gnutls/patches/002-ocsp-in-tools.patch
@@ -0,0 +1,51 @@
+diff --git a/src/cli-debug.c b/src/cli-debug.c
+index 5f9eb00..a8dde6c 100644
+--- a/src/cli-debug.c
++++ b/src/cli-debug.c
+@@ -165,8 +165,10 @@ static const TLS_TEST tls_tests[] = {
+ #endif
+ {"for max record size (RFC6066) support", test_max_record_size, "yes",
+ "no", "dunno"},
++#ifdef ENABLE_OCSP
+ {"for OCSP status response (RFC6066) support", test_ocsp_status, "yes",
+ "no", "dunno"},
++#endif
+ {"for OpenPGP authentication (RFC6091) support", test_openpgp1,
+ "yes", "no", "dunno"},
+ {NULL, NULL, NULL, NULL, NULL}
+diff --git a/src/common.c b/src/common.c
+index fff9449..ffa1896 100644
+--- a/src/common.c
++++ b/src/common.c
+@@ -572,9 +572,11 @@ int print_info(gnutls_session_t session, int verbose, int print_cert)
+ printf("- Options:");
+ if (gnutls_safe_renegotiation_status(session)!=0)
+ printf(" safe renegotiation,");
++#ifdef ENABLE_OCSP
+ if (gnutls_ocsp_status_request_get(session, &resp)==0) {
+ printf(" OCSP status request%s,", gnutls_ocsp_status_request_is_checked(session,0)!=0?"":"[ignored]");
+ }
++#endif
+ printf("\n");
+
+ #ifdef ENABLE_DTLS_SRTP
+diff --git a/src/tests.c b/src/tests.c
+index 6cb251d..5c45159 100644
+--- a/src/tests.c
++++ b/src/tests.c
+@@ -246,6 +246,7 @@ test_code_t test_safe_renegotiation(gnutls_session_t session)
+ return ret;
+ }
+
++#ifdef ENABLE_OCSP
+ test_code_t test_ocsp_status(gnutls_session_t session)
+ {
+ int ret;
+@@ -275,6 +276,7 @@ test_code_t test_ocsp_status(gnutls_session_t session)
+
+ return TEST_FAILED;
+ }
++#endif
+
+ test_code_t test_safe_renegotiation_scsv(gnutls_session_t session)
+ {