aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-08-18 16:38:43 -0400
committerGitHub <noreply@github.com>2016-08-18 16:38:43 -0400
commitea44cfddfed5f8a3222bb97876dc0b25262d0e92 (patch)
treee624214f7b8d934e8606dad5171f5b660da5bf41
parente128a2c3d9310d74fff6dfff79be56a0dc0c86c9 (diff)
parentf655a0dd01385c9b68648ce15d6578d9532e3953 (diff)
Merge pull request #3077 from commodo/tcpreplay-libnl-fix
tcpreplay: remove libnl dependency and update PKG_LICENSE_FILES.
-rw-r--r--net/tcpreplay/Makefile9
-rw-r--r--net/tcpreplay/patches/001-disable-dbus-link.patch12
2 files changed, 8 insertions, 13 deletions
diff --git a/net/tcpreplay/Makefile b/net/tcpreplay/Makefile
index 627abc5fd..6ff222502 100644
--- a/net/tcpreplay/Makefile
+++ b/net/tcpreplay/Makefile
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tcpreplay
PKG_VERSION:=4.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
PKG_MD5SUM:=80394c33fe697b53b69eac9bb0968ae9
PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=docs/LICENSE
PKG_FIXUP:=libtool
PKG_INSTALL:=1
@@ -124,6 +125,12 @@ define Package/tcpreplay-all/description
to support switches, routers, and IP Flow/NetFlow appliances.
endef
+CONFIGURE_VARS += \
+ ac_cv_lib_nl_nl_cache_alloc=no \
+ ac_cv_lib_nl_genl_3_genl_connect=no \
+ ac_cv_lib_nl_3_nl_cache_alloc=no \
+ ac_cv_lib_dbus_1_dbus_malloc=no
+
CONFIGURE_ARGS += \
--enable-force-pf \
--enable-dynamic-link \
diff --git a/net/tcpreplay/patches/001-disable-dbus-link.patch b/net/tcpreplay/patches/001-disable-dbus-link.patch
deleted file mode 100644
index 6f34e9fc8..000000000
--- a/net/tcpreplay/patches/001-disable-dbus-link.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 6c61381..7f72871 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -773,7 +773,6 @@ if ! test $using_pcap_config = yes; then
- AC_CHECK_LIB(nl, nl_cache_alloc, [nl_found=yes])
- AC_CHECK_LIB(nl-genl-3, genl_connect, [nl_genl_3_found=yes])
- AC_CHECK_LIB(nl-3, nl_cache_alloc, [nl_3_found=yes])
-- AC_CHECK_LIB(dbus-1, dbus_malloc, [dbus_1_found=yes])
- if test "$nl_found" = "yes"; then
- LPCAPLIB="$LPCAPLIB -lnl"
- fi