aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-02-15 09:17:48 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2018-02-15 09:17:48 +0200
commite8e827c2c6602ecc684ffb05f36d5ab7ce043ad3 (patch)
tree7ab761775309dcab81ffdfd3d819b2396c57168e
parenta576b1d82986ba7cbf6d37bfc41afcdf387b3cde (diff)
Revert "openvswitch: remove dependency on kernel version"
This reverts commit 44df061c48c34010f5db19e855b112ad3aef4d2d. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
-rw-r--r--net/openvswitch/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 2d51e1b9e..ee3cd0aaa 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -29,6 +29,8 @@ PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+SUPPORTED_KERNELS:=LINUX_3_18||LINUX_4_1||LINUX_4_3||LINUX_4_4||LINUX_4_9
+
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python-package.mk
@@ -53,7 +55,7 @@ endef
define Package/openvswitch-base
$(call Package/openvswitch/Default)
TITLE:=Open vSwitch Userspace Package (base)
- DEPENDS:=+libpcap +libopenssl +librt +kmod-openvswitch
+ DEPENDS:=+libpcap +libopenssl +librt +kmod-openvswitch @($(SUPPORTED_KERNELS))
endef
define Package/openvswitch-base/description