aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-10-11 09:40:08 +0800
committerGitHub <noreply@github.com>2023-10-11 09:40:08 +0800
commite8597c2a7f08c59bf05acdaba6be0c1e73b99628 (patch)
tree15d6094662c160c3ebe2f840c03994cd4f307fe2
parent482e7170e884eeb8e98582df3cb12426b7e83bb4 (diff)
parentfd1d506fff9462b3329585bdd148a6fd78cbd27a (diff)
Merge pull request #22345 from muink/patch-1
librespeed-go: Reload the daemon after modifying the tls certificate
-rw-r--r--net/librespeed-go/Makefile2
-rw-r--r--net/librespeed-go/files/librespeed-go.init7
2 files changed, 6 insertions, 3 deletions
diff --git a/net/librespeed-go/Makefile b/net/librespeed-go/Makefile
index ddef5b563..984370e64 100644
--- a/net/librespeed-go/Makefile
+++ b/net/librespeed-go/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=librespeed-go
PKG_VERSION:=1.1.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/librespeed/speedtest-go/tar.gz/v$(PKG_VERSION)?
diff --git a/net/librespeed-go/files/librespeed-go.init b/net/librespeed-go/files/librespeed-go.init
index 13c333c1a..7ff2c7668 100644
--- a/net/librespeed-go/files/librespeed-go.init
+++ b/net/librespeed-go/files/librespeed-go.init
@@ -12,6 +12,7 @@ mount_jail_file() {
local cfg="$1"
local isdir="${2:-0}"
local rw="${3:-0}"
+ local reload="${4:-0}"
local value
config_get value "config" "$cfg"
@@ -31,6 +32,8 @@ mount_jail_file() {
else
procd_add_jail_mount "$value"
fi
+
+ [ "$reload" = "0" ] || procd_append_param file "$value"
}
start_service() {
@@ -74,8 +77,8 @@ start_service() {
mount_jail_file "assets_path" "1"
mount_jail_file "database_file" "0" "1"
- mount_jail_file "tls_cert_file"
- mount_jail_file "tls_key_file"
+ mount_jail_file "tls_cert_file" "0" "0" "1"
+ mount_jail_file "tls_key_file" "0" "0" "1"
procd_close_instance
}