aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Palsson <karlp@remake.is>2015-09-21 11:42:02 +0000
committerKarl Palsson <karlp@remake.is>2015-09-23 10:30:48 +0000
commite7bd3fbe210d8d593b054c0cd5ced07ef71f7fd0 (patch)
tree0c161baff1a06c5c850908c2325334812d684081
parente2837aecae94f20356ba6b10113676a24da2968f (diff)
mosquitto: upgrade to version 1.4.4
Drop patch now included upstream. More information: http://mosquitto.org/2015/09/version-1-4-4-released/ Signed-off-by: Karl Palsson <karlp@tweak.net.au>
-rw-r--r--net/mosquitto/Makefile6
-rw-r--r--net/mosquitto/patches/001-free-counting-bug-475707.patch14
2 files changed, 3 insertions, 17 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 1aac9d872..87ff529e8 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
-PKG_VERSION:=1.4.3
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.4
+PKG_RELEASE:=1
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
-PKG_MD5SUM:=1c1c750525546bc13d8d72e56a0742a7
+PKG_MD5SUM:=89a57f11cdfec140fa21fe3d4493b2ca
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
diff --git a/net/mosquitto/patches/001-free-counting-bug-475707.patch b/net/mosquitto/patches/001-free-counting-bug-475707.patch
deleted file mode 100644
index 6b1614569..000000000
--- a/net/mosquitto/patches/001-free-counting-bug-475707.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/lib/memory_mosq.c b/lib/memory_mosq.c
-index b1f5bfd..4d8217d 100644
---- a/lib/memory_mosq.c
-+++ b/lib/memory_mosq.c
-@@ -54,6 +54,9 @@ void *mosquitto__calloc(size_t nmemb, size_t size)
- void mosquitto__free(void *mem)
- {
- #ifdef REAL_WITH_MEMORY_TRACKING
-+ if(!mem){
-+ return;
-+ }
- memcount -= malloc_usable_size(mem);
- #endif
- free(mem);