aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-01 23:35:26 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-01 23:35:26 -0800
commite6919c19cbb810ffc887eba5c437b56028f693ab (patch)
tree7b298bbc7986abf03580e825924303fb613d5736
parent5bae7c73a767ac67428142066d74b3e056a1ff16 (diff)
emailrelay: Remove unnecessary OpenSSL engine include
There's no usage of any ENGINE APIs and trying to include the header breaks compilation with ENGINE support disabled. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--mail/emailrelay/Makefile2
-rw-r--r--mail/emailrelay/patches/020-openssl-engine.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/mail/emailrelay/Makefile b/mail/emailrelay/Makefile
index d0ef0e341..cef6e22c0 100644
--- a/mail/emailrelay/Makefile
+++ b/mail/emailrelay/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=emailrelay
PKG_VERSION:=2.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
PKG_SOURCE_URL:=@SF/emailrelay/$(PKG_VERSION)
diff --git a/mail/emailrelay/patches/020-openssl-engine.patch b/mail/emailrelay/patches/020-openssl-engine.patch
new file mode 100644
index 000000000..d10d69478
--- /dev/null
+++ b/mail/emailrelay/patches/020-openssl-engine.patch
@@ -0,0 +1,10 @@
+--- a/src/gssl/gssl_openssl.cpp
++++ b/src/gssl/gssl_openssl.cpp
+@@ -32,7 +32,6 @@
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
+ #include <openssl/rand.h>
+-#include <openssl/engine.h>
+ #include <openssl/conf.h>
+ #include <openssl/evp.h>
+ #include <openssl/hmac.h>