aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 21:04:07 -0800
committerGitHub <noreply@github.com>2020-12-07 21:04:07 -0800
commite5a0331846858b4b4bb189821de605e1556adf00 (patch)
tree20b49df97b138095abe2e9cf19df8c559057f0ce
parentc2cc52f2f17247cb792157a42496d286b0205bba (diff)
parent5e814c7972feddfedd8c5ea4107a4a3f969b10e8 (diff)
Merge pull request #14170 from neheb/pcre222
pcre2: install pcre2-config to host path
-rw-r--r--libs/pcre2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/libs/pcre2/Makefile b/libs/pcre2/Makefile
index 28743ba19..d3172e662 100644
--- a/libs/pcre2/Makefile
+++ b/libs/pcre2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pcre2
PKG_VERSION:=10.35
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/pcre/$(PKG_NAME)/$(PKG_VERSION)
@@ -68,9 +68,9 @@ CMAKE_OPTIONS += \
define Build/InstallDev
$(call Build/InstallDev/cmake,$(1))
- $(SED) \
- 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
- $(1)/usr/bin/pcre2-config
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/pcre2-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/pcre2-config $(2)/bin/pcre2-config
endef
define Package/libpcre2/install