aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-21 19:21:04 -0800
committerRosen Penev <rosenp@gmail.com>2020-02-23 15:00:08 -0800
commite547169c513ed8ad277d81b2aa70ace668341b25 (patch)
tree0aff6c4a2bc46d32e42966f17937c530cdb2c3b4
parent5af9f00c26bf903ad87d06ea595feb7fa955e683 (diff)
protobuf-c: update to 1.3.3
Refreshed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/protobuf-c/Makefile6
-rw-r--r--libs/protobuf-c/patches/010-pkgconfig.patch4
2 files changed, 5 insertions, 5 deletions
diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index a7b5bed45..6b66666ba 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libprotobuf-c
-PKG_VERSION:=1.3.2
-PKG_RELEASE:=4
+PKG_VERSION:=1.3.3
+PKG_RELEASE:=1
PKG_SOURCE:=protobuf-c-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/protobuf-c/protobuf-c/releases/download/v$(PKG_VERSION)
-PKG_HASH:=53f251f14c597bdb087aecf0b63630f434d73f5a10fc1ac545073597535b9e74
+PKG_HASH:=22956606ef50c60de1fabc13a78fbc50830a0447d780467d3c519f84ad527e78
PKG_BUILD_DIR:=$(BUILD_DIR)/protobuf-c-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/protobuf-c-$(PKG_VERSION)
diff --git a/libs/protobuf-c/patches/010-pkgconfig.patch b/libs/protobuf-c/patches/010-pkgconfig.patch
index c0506ab27..932d5cf73 100644
--- a/libs/protobuf-c/patches/010-pkgconfig.patch
+++ b/libs/protobuf-c/patches/010-pkgconfig.patch
@@ -3,7 +3,7 @@
@@ -1,7 +1,10 @@
SET(PACKAGE protobuf-c)
SET(PACKAGE_NAME protobuf-c)
- SET(PACKAGE_VERSION 1.3.2)
+ SET(PACKAGE_VERSION 1.3.3)
+set(PACKAGE_URL https://github.com/protobuf-c/protobuf-c)
+set(PACKAGE_DESCRIPTION "Protocol Buffers implementation in C")
@@ -11,7 +11,7 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.8 FATAL_ERROR)
-@@ -137,6 +140,9 @@ IF(CMAKE_HOST_UNIX)
+@@ -141,6 +144,9 @@ IF(CMAKE_HOST_UNIX)
INSTALL(CODE "EXECUTE_PROCESS (COMMAND ln -sf protoc-gen-c protoc-c WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/bin)")
ENDIF()