aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-06-26 22:52:16 -1000
committerPaul Spooren <mail@aparcar.org>2020-06-27 10:30:29 -1000
commite2fe9bda3d6a2755f36031d8d69c6ea8e08ba715 (patch)
tree9f72cf8b8a315387a97d4f44084bb7bfd58ca1b4
parentab5bbd9b253904bc6467f540dea3e529f4b69cfb (diff)
syncthing: Fix GO_PKG_LDFLAGS_X position
Setting the GO_PKG_LDFLAGS_X after including golang-package does not include them anymore after commit 25a7f00. By adding flags before they are correctly loaded and included in `syncthing` binary. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--utils/syncthing/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/utils/syncthing/Makefile b/utils/syncthing/Makefile
index 4a0e781da..c57730d2e 100644
--- a/utils/syncthing/Makefile
+++ b/utils/syncthing/Makefile
@@ -23,6 +23,13 @@ GO_PKG:=github.com/syncthing/syncthing/
GO_PKG_BUILD_PKG:=github.com/syncthing/syncthing/cmd/syncthing/
GO_PKG_INSTALL_EXTRA:=^gui/
+GO_PKG_LDFLAGS_X:=\
+ github.com/syncthing/syncthing/lib/build.Version=v$(PKG_VERSION) \
+ github.com/syncthing/syncthing/lib/build.Stamp=$(SOURCE_DATE_EPOCH) \
+ github.com/syncthing/syncthing/lib/build.User=openwrt \
+ github.com/syncthing/syncthing/lib/build.Host=openwrt \
+ github.com/syncthing/syncthing/lib/build.Program=syncthing
+
include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
@@ -35,13 +42,6 @@ define Package/syncthing
USERID:=syncthing:syncthing
endef
-GO_PKG_LDFLAGS_X:=\
- github.com/syncthing/syncthing/lib/build.Version=v$(PKG_VERSION) \
- github.com/syncthing/syncthing/lib/build.Stamp=$(SOURCE_DATE_EPOCH) \
- github.com/syncthing/syncthing/lib/build.User=openwrt \
- github.com/syncthing/syncthing/lib/build.Host=openwrt \
- github.com/syncthing/syncthing/lib/build.Program=syncthing
-
define Build/Compile
$(call GoPackage/Build/Compile,-tags noupgrade)
endef