aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-08-03 08:04:27 +0200
committerSteven Barth <steven@midlink.org>2015-08-03 08:04:27 +0200
commite23bc0e76a6016755b7c4fb3bf9177090683e5b1 (patch)
treeb5e1ccf9002ff36a8a9c2c75cce2b4a9cc274ad5
parent3b3542cc5ffd3afb3ebdc10ae8fa8c1e369d39c2 (diff)
parentce13ffa1d6c055b3dd3fac769a0682796e8b1221 (diff)
Merge pull request #1612 from changeway/libstrophe
Add libstrophe : XMPP client library
-rw-r--r--libs/libstrophe/Config.in14
-rw-r--r--libs/libstrophe/Makefile65
2 files changed, 79 insertions, 0 deletions
diff --git a/libs/libstrophe/Config.in b/libs/libstrophe/Config.in
new file mode 100644
index 000000000..ec45f754c
--- /dev/null
+++ b/libs/libstrophe/Config.in
@@ -0,0 +1,14 @@
+choice
+ depends on PACKAGE_libstrophe
+ prompt "Select XML library"
+ default libstrophe-expat
+
+config libstrophe-expat
+ bool "expat"
+ select PACKAGE_libexpat
+
+config libstrophe-libxml2
+ bool "libxml2"
+ select PACKAGE_libxml2
+
+endchoice
diff --git a/libs/libstrophe/Makefile b/libs/libstrophe/Makefile
new file mode 100644
index 000000000..662791650
--- /dev/null
+++ b/libs/libstrophe/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libstrophe
+PKG_VERSION:=0.8.7
+PKG_RELEASE=1
+
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Chih-Wei Chen <changeway@gmail.com>
+
+PKG_SOURCE_URL:=https://github.com/strophe/libstrophe/archive/
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_libstrophe-libxml2 \
+ CONFIG_libstrophe-expat
+
+include $(INCLUDE_DIR)/package.mk
+
+ifeq ($(CONFIG_libstrophe-libxml2),y)
+CONFIGURE_ARGS += \
+ --with-libxml2
+endif
+
+define Package/libstrophe
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=XMPP client library
+ URL:=http://strophe.im/libstrophe
+ DEPENDS:= +libopenssl +libstrophe-libxml2:libxml2 +libstrophe-expat:libexpat
+ MENU:=1
+endef
+
+define Package/libstrophe/description
+ A simple, lightweight C library for writing XMPP clients
+endef
+
+define Package/libstrophe/config
+ source "$(SOURCE)/Config.in"
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ $(1)/usr/
+
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstrophe.{la,a,so*} $(1)/usr/lib/
+endef
+
+define Package/libstrophe/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstrophe.so.* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,libstrophe))