aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Miguel Ferreira <carlosmf.pt@gmail.com>2018-08-21 02:13:59 +0100
committerCarlos Miguel Ferreira <carlosmf.pt@gmail.com>2018-08-21 02:13:59 +0100
commite0e80c1d2c8b94a3568c67c48280cf7da38d3ec0 (patch)
tree213168226df5401efebc14cb166441003bb3da34
parentd9749c257b733ed3f193d7c22512a89ebd32a29b (diff)
boost: Package Version Update -> 1.68.0
This package update provides one new library: - YAP: An expression template library for C++14 and later, from Zach Laine [1]. More info can be found at the usual place [2]. [1] : https://www.boost.org/libs/yap/ [2] : https://www.boost.org/users/history/version_1_68_0.html Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
-rw-r--r--libs/boost/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index e7ffd91b3..a9e768dd5 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -16,15 +16,15 @@ include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
-PKG_VERSION:=1.67.0
-PKG_SOURCE_VERSION:=1_67_0
-PKG_RELEASE:=2
+PKG_VERSION:=1.68.0
+PKG_SOURCE_VERSION:=1_68_0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_SOURCE_VERSION)
-PKG_HASH:=2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba
+PKG_HASH:=7f6130bc3cf65f56a618888ce9d5ea704fa10b462be126ad053e80e553d6d8b7
PKG_LICENSE:=Boost Software License <http://www.boost.org/users/license.html>
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
@@ -44,7 +44,7 @@ define Package/boost/Default
endef
define Package/boost/description
-This package provides the Boost v1.67.0 libraries.
+This package provides the Boost v1.68.0 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.
-----------------------------------------------------------------------------
@@ -63,7 +63,7 @@ This package provides the following run-time libraries:
- chrono
- container
- context
- - contract (new in 1.67.0)
+ - contract
- coroutine (Deprecated - use Coroutine2)
- - coroutine2 (Requires GCC v5 and up)
- date_time