aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-02 01:04:08 -0700
committerGitHub <noreply@github.com>2020-04-02 01:04:08 -0700
commite0162a3fbf42ad2d67de343cb19cc5bf0310b8b6 (patch)
tree83049bb6a4cf3224245b881aa1e2e962f23c112e
parent3732cab3dfe711f9a445b1abff61178fd7c5519e (diff)
parent89ddb6baca45aa5c10747482afa5b9907e19874b (diff)
Merge pull request #11711 from neheb/atftpd
atftp: fix compilation with newer musl
2 files changed, 23 insertions, 1 deletions
diff --git a/net/atftp/Makefile b/net/atftp/Makefile
index ea6838776..ddd3281f3 100644
--- a/net/atftp/Makefile
+++ b/net/atftp/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=atftp
PKG_VERSION:=0.7.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/net/atftp/patches/04-cdefs.patch b/net/atftp/patches/04-cdefs.patch
new file mode 100644
index 000000000..1d3f3e2e8
--- /dev/null
+++ b/net/atftp/patches/04-cdefs.patch
@@ -0,0 +1,22 @@
+--- a/argz.h
++++ b/argz.h
+@@ -39,6 +39,7 @@
+ #define _ARGZ_H 1
+
+ #include <features.h>
++#include <sys/cdefs.h>
+
+ #define __need_error_t
+ #include <errno.h>
+@@ -76,9 +77,9 @@ extern error_t argz_create_sep (__const char *__restrict __string,
+
+ /* Returns the number of strings in ARGZ. */
+ extern size_t __argz_count (__const char *__argz, size_t __len)
+- __THROW __attribute_pure__;
++ __THROW;
+ extern size_t argz_count (__const char *__argz, size_t __len)
+- __THROW __attribute_pure__;
++ __THROW;
+
+ /* Puts pointers to each string in ARGZ into ARGV, which must be large enough
+ to hold them all. */